Forum > Debugger

FpDebug problem

(1/4) > >>

440bx:
Hello,

When debugging using FpDebug, using the trunk version of FPC and Lazarus, the writeln(s) in the attached project are not output and eventually subsequent writeln(s) cause a runerror(101) to occur. 

The writeln(s) appear without problem when the project is debugged using GDB.

Also attached is a screenshot of the Lazarus and FPC versions.  O/S is Win 7, 64bit, SP1.

Comments welcome.

NOTE: I do not know if the problem also occurs in a different versions of Lazarus/FPC because the project requires FPC trunk to compile.


Martin_fr:
While I am looking, have you tried "run without debug"?

Martin_fr:
I just rebuild my IDE with FPC 1546c4a7947afcb45783b1251b01fd31016ef84d

When I run the project under FpDebug the "test" is printed as it should. (Then it hits the breakpoint, and exits)

I am on Win10 / 64 bits.

Martin_fr:
FpDebug does not really do anything about the StdOut, or writeln.

It use TProcess from FPC (and TProcess changed in FPC trunk), to start the process, and that tell Windows which handles the new process should have.

marcov:
Note that were updates in the last two days. If your trunk is even of yesterday morning, please retest.

Navigation

[0] Message Index

[#] Next page

Go to full version