Forum > Android

LAWM - Gradle Panic error

<< < (5/5)

iru:
Attempted to install LAWM as follows{

I have woIrked my through the LAMW document (https://github.com/jmpessoa/lazandroidmodulewizard).
I startedat 2, Infrastructure Setup :: only for non-users of "LAWM...."

Downloaded and installed
   JDK 21, Gradle 8.5 SDKj21

Executed 'sdkmanager "build-tools;34.0.0" "Platforms:android-34" "platform-tools".

Downloaded the NDK r21e.
Downloaded Gradle 8.5.

So I think I have everything required.

Used fpcupdeluxe to build a new 'stable' fpc and Laz environment.

In the LAZ IDE selected 'Package>Open Package file (.lpk)
Selected 'lazandroidmodulewizard-master/android-bridges/tfpandroidbridge_pack.lpk

In the package install window selected 'Install', etc.
When prompted selected 'Rebuild the IDE', etc the recompile/build of Laz commenced.

Failed-Linking error in the lazarus .LPR.....

make[2]: *** [Makefile:4362: lazarus] Error 1
make[1]: *** [Makefile:4801: ide] Error 2
*** [Makefile(3116,0) Error: linker: ide] Error 2
lazarus.pp(171,1) Error: Error while linking
lazarus.pp(171,1) Verbose: There were 1 errors compiling module, stopping
Verbose: Compilation aborted

I will think about things....

Ian

 

iru:
Gentlefolk,
I have had little time to work on this...

However I have managed to borrow a laptop with windows 10. Will load up LAZ and LAWM and see if I can get the job done.....

Ian.

marcos-ebm:
[using the translator]

download version 2.4.0c of fpcupdeluxe, as the stable version of lazaruas is version 3

after installing lazarus/fpc, install ARM - ANDROID

After that, you install LAMW (manually like you did)

When starting a new lamw project, always choose the ARMv7a+VFPv3 option

Navigation

[0] Message Index

[*] Previous page

Go to full version