Forum > Android

LAWM - Gradle Panic error

<< < (3/5) > >>

jmpessoa:

Hi, Iru!

What is your JDK version?  check here:

Java JDK 21: Gradle 8.5 or up
Java JDK 17: Gradle 8.2.1 or up
Java JDK 11: Gradle 7.6.3 or up
Java JDK 1.8: Gradle 6.7 or down

WayneSherman:

--- Quote from: iru on January 27, 2024, 06:41:56 am ---Environment: Linux Mint 21.1, Laz, FPC and Android from instructions in
   https://wiki.freepascal.org/LAMW_install_linux_fpcupdeluxe

When I use'Run> [LAWM] build APK and  Run to crate a simple APK......
I get a terminal window which displays  a lot of text, displays what appears to be an error message (Red text) and then  closes and the following IDE message/s are displayed:

--- End quote ---

Instead of using "Run> [LAWM] build APK and  Run" do the following:

Use "Run" | "Build" and if the build is successful open a terminal in the project folder and run ./gradle-local-build.sh to build the APKs.  You will be able to see the error messages in the terminal.

iru:
Gentlefolk,

Thank you for your responses.
Reviewing what was installed and the >Tools>LAMW Paths/Settings I see I am using

/usr/lib/jvm/java-11-openjdk-amd64 and Gradle 6.8.3 a combination not supported.....

So off I go to download and instal the latest (and complimentary) sdk, ndk, gradle, etc.......

This may take some time as I have a lot of things on at the moment...

Thank you, Ian.

WayneSherman:

--- Quote from: iru on January 28, 2024, 03:45:02 am ---Gradle 6.8.3 a combination not supported.....

--- End quote ---

I haven't test this version of gradle since recent LAMW updates.  This is the gradle version that fpcupdeluxe installs at the moment.

iru:
Wayne,

Thank you for your suggestion of breaking the build-run process into 2 steps.

On executing: ./gradle-local-build.sh The following was displayed.

ERROR: JAVA_HOME is not set and no 'java' command could be found in your PATH.

This may not be the original error because I have been fiddling with things and may have bent or broken something....

It would appear the best way forward is build  clean Linux, install all the android-java-whatever bits and pieces again.

I battle slowly on.... Ian

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version