Forum > Windows (32/64)

"Access Violation" while starting lazarus (Windows7)


Hi, I'm new to this forum,
 but programming Lazarus (and before Delphi) for some years.

Now I run into a problem while updating a Lazarus 2.0.6 to 2.2.4 or 2.2.6 on a Windows 7 x64 Computer running in VMWare.

After uninstall the previous installation, deleting the lazarus-folder and new install of Lazarus, I'm not able to start Lazarus.
I can see the windows of Lazarus starting, then the application reports "read error  -  Access violation"
When I click on the dialog, the dialog disappears, but the executable stays active and has to be killed by taskmanager.

unfortunatly, the application don't tell me, what it can't read...  :(

I tried to instal some versions of Lazarus "2.2.4 Win64" "2.2.4 Win32" "2.2.6 Win64"

in a post out of this forum, I read about starting lazarus out of gdb, but gdb only tells me, that there are no debugging symbols...  %)

any idea how to solve this?

many thanks Gabriel

try to start the IDE from a shell/terminal window (you can use the startlazarus executable for that). That allows Lazarus to emit some detailed information in the shell.terminal window and which might be able to give a hint on what is happening.

You can build Lazarus with debug information but that requires more work and extra build time, the above suggestion can be tried much faster.

Thank you TRon!
because of other failures in this virtual machine, we decided to make the virtual machine new...

many thanks Gabriel


[0] Message Index

Go to full version