Forum > macOS / Mac OS X

Hiding terminal window on macos lazarus app startup.

(1/2) > >>


I'm using Lazarus 3.0 (rev ) FPC 3.2.2 x86_64-darwin-cocoa and running on MacBook Pro M2 2022 14.2.1 (23C71) Sonoma 14.2.1 (23C71).

I've already disable debugging and enable Win32 Gui Application config & target on Project option, but the shell window is still displaying at the app startup.

Is there a way to prevent the shell window from displaying ?

Kind regards,
Ahmad R. Djarkasih

Did you click the "Create Application Bundle" button in the "Project" -> "Project Options" window?
(not sure if that is still needed)

Sounds like you're starting the executable and not the .app bundle?

I don't know about "run without debugger" ...

But, if your app does not itself open a console, and does not have anything that makes the OS do so...

In menu: Tools > Options >> Debugger Backend
There is property grid, where you can check/uncheck if the debugger should open a console for your app.
At least that used to work... Not sure, if Apple changed something (again).

Thx for the reply guys.

Hansaplast : I click the button, but nothing happen.
Martin_fr: In my IDE there is no Options menu under Tools menu. In project option in Backend Converter or in other part of Debugger leaf, there is no checkbox to control wheter or not debugger should open the console for the app.

Clicking the button should create a .app bundle with the name of your project, in your project folder.
Something like "" (if your project is called project1). By default this ".app" extension is not shown in Finder unless you've set Finder to show all extensions (in Finder -> Settings -> Advanced -? check "Show all filename extensions").
You can right click it in Finder and the menu should show "Show Package Contents" which reveals the directory structure of the .app bundle.


[0] Message Index

[#] Next page

Go to full version