Forum > macOS / Mac OS X

[Solved] Brand new clean installation but so many problems with IDE

(1/2) > >>

Wilko500:
Lazarus 3.0 - FPC 3.2.2 - macOS Monterey 12.7.2

I have a virtual (Parallels) Windows 7 Lazarus installation that works very well. In an attempt to begin the migration process of my ancient VB6 and more recent FPC apps to MacOS I have install Lazarus and FPC onto my MacBook Pro.

I followed the documented 5 step installation process to the letter and it all worked.  Problems started with using the Lazarus IDE. While I am very happy with the GUI appearance in Windows I am NOT happy with the GUI appearance in Mac.  As I see it it is so poor that I consider it almost unusable. List of initial issues below, I'm sure there will be many more as I try more complicated controls.

My testing was to create a new project using the guide "Crash Course Lazarus 1 - Setting up a new project". Now while it is true that I can get my test project to work the process is intensely frustrating.

My question is simple.  Is what I am experiencing expected in a Mac environment or have I missed some fundamentally (undocumented) step(s) that will improve matters? 

One option is to stay with the Windows version of Lazarus but there are problems ahead. I have no desire to move from Windows 7 since it does what I need. All software upgrade paths will lead to incompatibilities with my current hardware and significant expense.

Thank you for reading my post and I look forward to suggestions

Problems
1. Almost every attempt to insert a new control onto a form results in some form of Unit not found error. Also any attempt to create an event by clicking the ellipse on the event cause a popup window with a message to fix the error in the message window.  It seems that selecting a control and then clicking on the form should add the control to the form AND and the appropriate header while clicking to create an event should add code. For me I get one or the other but rarely both. I am unable to determine why it works occasionally.

I have read the lengthy help on "Finding Units" most of which is not relevant because it refers to incorrect typing of names, paths, slashes etc etc while all I have done is point and click within the IDE.  Sometimes Rescan FPC source directory will fix it sometimes not.  Sometime just doing a compile will fix it sometimes not. Sometimes I have to quit Lazarus and start over.

2. The form/control styling out of the box is IMHO just awful.  The default colours, styles and borders make labels, buttons and edits  quite hard to read and see on the form

3. I am unable to change label colour or font colour using the properties, they just don't make any difference.

4. The edit box font colour can be changed in code but nit by properties from IDE

5. Inability to output a debug message to either the message window or to the console.  I have tried following several methods as found on the "net". None work of me.

All these problems seem to exist only in Mac environment

madref:
Have you tried fpcupdeluxe to install a version of lazarus and fps.
You can even install a trunk-version. This makes installing lazarus easier


Try it and see what happens.


I use BGRA Controls as a component and it works great (for me).


Hope this helps

Dzandaa:
Hi,

I use Lazarus v 2.2.4 FPC 3.2.2 on Windows 7, 10, Linux Mint 20.3 and MacOS Sierra without problem.

I's just slower at compilation on MAC.

Most of the time, I write my programs on Win7 then copy on MacOS and Linux to recompile without problem.

First I install
AnchorDockingDsgn 1.0
from "Install/Uninstall Package"

Then

BGRABitmap
BGRAControls
ColorPalette
DCPcrypt
DMatch
Indy10
LazMapViewer
LazSerial
LCLExtensions
LGenerixs
MultithreadProcs
PascalTZ
pl_SynapseVS
RichMemo
Sdpo
Synapse40.1
VirtualRreeViewV5

From "Online Package Manager"

B->

Wilko500:
I have noticed the slower compilation on Mac!  And I too have moved a working Windows FPC program and found that recompiling is ok notwithstanding the few Windows API calls I had to deal with. The styling though still leaves a lot to be desired.

I must say I am drawn to the idea of designing in Windows and then recompiling on Mac.

Thank you for your list of supplementary installs. I will certainly investigate these and try them out. Perhaps they will make all the difference.

Wilko500:

--- Quote from: Dzandaa on January 06, 2024, 03:51:02 pm ---
First I install
AnchorDockingDsgn 1.0
from "Install/Uninstall Package"

B->

--- End quote ---

This failed for me!! First  I selected install AnchorDockingDsgn 1.0 then Save & Rebuild IDE then got the following error

datetimepicker.pas(85,12) Error: Can't find unit DateTimePicker used by DateTimeCtrls

Attempting to uninstall the AnchorDockingDsgn fails with a similar message.

Moving on the items eg BGRAControls the installer claims they are installed then I am asked if I want to rebuild the IDE.  I presumed that the answer is yes in which case I get a failure with error

datetimepicker.pas(85,12) Error: Can't find unit DateTimePicker used by DateTimeCtrls.




Navigation

[0] Message Index

[#] Next page

Go to full version