Recent

Author Topic: Lazarus Release 3.0  (Read 107044 times)

dbannon

  • Hero Member
  • *****
  • Posts: 2842
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Lazarus Release 3.0
« Reply #135 on: January 28, 2024, 11:51:56 pm »
hello people i tried this again.
......

But you did it the same way and we know that has a problem. fpcupdeluxe is a really great product and very suited to someone who wants a totally automated way of installing anywhere. But its installing FPC3.2.2 and we know that has a problem with 32bit Linux.

I'd suggest you install by hand, you are a developer, I've see you here quite a bit and you most certainly understand whats needed. And, honestly, IMHO, installing, bit by bit does leave with a clear picture of the system and that makes fixing problems or doing something slightly different easy.

But I understand you want an auto way ?  I have attached a script I use when testing on multiple VMs. Its definitely NOT in any way a substitute or even a rival for fpcupdeluxe - its a totally one trick pony. But right now, at this point in time, that one trick is the appropriate one to use. Please humor me and give it a try.

$> bash ./make_fpc_lazarus.bash <enter>

Build a new VM and run my script as yourself. It will ask for the root PW to install the repo FPC and then manage the Lazarus install, depending on your desktop, you will see a lazarus entry in the menus.

I really must emphasis that this script is not a general purpose tool for installing Lazarus, its just something I keep around when firing up multiple VMs. Debian based only VMs. And it installs ONLY FPC 3.2.2 and Lazarus 3.

(Hey, as a postscript, are you using Virtual Box's "clone" facility ?  Build your VM, bring it up to date, maybe a few settings like screen size and allowing sudo. Then shut it down and clone it. Do you experimenting on the clone, make a mistake or need to start again ? Blow the clone away and make a new one in seconds.)

Davo
Lazarus 3, Linux (and reluctantly Win10/11, OSX Monterey)
My Project - https://github.com/tomboy-notes/tomboy-ng and my github - https://github.com/davidbannon

TRon

  • Hero Member
  • *****
  • Posts: 2641
Re: Lazarus Release 3.0
« Reply #136 on: January 29, 2024, 12:10:41 am »
That is soon 3 years ago!
Yes, I am painfully aware.

Personally, I would not mind annual bug-fix releases as they would be very welcome  :)

And to try bring it back on topic it would be very helpful for Lazarus as well.

fpcupdeluxe is a really great product and very suited to someone who wants a totally automated way of installing anywhere. But its installing FPC3.2.2 and we know that has a problem with 32bit Linux.
Just for the record, FPCUpDeluxe does have an option for installing 3.2 fixes (as well as trunk). The only thing Ido not know for sure if it will always pull the latest sources because choosing gitlab for downloading the source-code is optional in FPCUpDeluxe (it will pull from FPCUpDeluxe's sources otherwise and no idea how much they get refreshed).

That does not imply that there is something wrong with your script though.

This is getting more and more off-topic. This is an announcement thread about Lazarus, not FPC, FPCUpDeluxe or otherwise. If TS has specific questions regarding other topics then he/she can choose the appropriate (sub)forums for that   :-X

« Last Edit: January 29, 2024, 12:13:39 am by TRon »

StoneAge

  • New Member
  • *
  • Posts: 13
Re: Lazarus Release 3.0
« Reply #137 on: January 29, 2024, 12:09:51 pm »
I'd like to add my huge thanks to ALL of you involved in creating (any of the original Borland people still here ) maintaining, and updating Lazarus and FPC.  And every one of you who give of your time and knowledge to help others. THANK YOU!

calebs

  • Full Member
  • ***
  • Posts: 191
Re: Lazarus Release 3.0
« Reply #138 on: January 30, 2024, 03:42:31 am »
Thanks JuhaManninen and everybody. I'll do it again just to double check steps. Anyway, i use fpcupdeluxe since it always was the better and simpler way to mantain lazarus installed with fixes branch in 4 systems at a time. Since i had difficulties to crosscompiling i opted to have a pc and 3 vm's, one windows 11x64 for main developing, one win 10x86, linux debian /antix 32 and 64 bits, all with the same packages to compile my program in every system needed.
And since i've discovered fpcupdeluxe always using it to:
download stable fpc and fixes lazarus.
Now, i've tried to download fpc 3.2 fixes branch and fixes lazarus and it installs and compiles well. Added some standard components like messagecomposer, printer4laz and online package and all installed well.
But now i've crashed with a problem that i had everytime i got out from current fpc and is zeos not installing zcomponent with error of 7 parameters or something else
Even download zeos 8 from git and tried too but crashed compilation with error in zasbstractrodataset.pas expected another 1 array element.
any recipe to make work zeos out of stable 3.2.2 fpc?
Thanks!

dbannon

  • Hero Member
  • *****
  • Posts: 2842
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Lazarus Release 3.0
« Reply #139 on: January 30, 2024, 04:44:49 am »
....
any recipe to make work zeos out of stable 3.2.2 fpc?

calebs, as TRon suggested, these issues do not belong in the Lazarus 3.0 release thread. Your may have a FPC issue or it may be a Zeos issue, in either case, please post a new message under the appropriate heading. Probably a good idea to look into those error messages too, eg, if something is expecting 7 parameters and something else is offering a number other than 7, have a look at why ? What has changed ? 

Davo
Lazarus 3, Linux (and reluctantly Win10/11, OSX Monterey)
My Project - https://github.com/tomboy-notes/tomboy-ng and my github - https://github.com/davidbannon

zeljko

  • Hero Member
  • *****
  • Posts: 1600
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Lazarus Release 3.0
« Reply #140 on: January 30, 2024, 09:32:35 am »
@calebs, you have problem with some db field type enums which are extended in fpc fixes, so different that fpc-3.2.2.
If you want to work then use 3.2.2, otherwise patch zeos to compile (I did it few months ago on one of my devel machines, but could not access that machine atm to provide you patch for zeos).

dbannon

  • Hero Member
  • *****
  • Posts: 2842
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Lazarus Release 3.0
« Reply #141 on: January 30, 2024, 09:49:59 am »
Yes, I know I am extending this discussion under the wrong heading but I cannot help myself !

@calebs, you have problem with some db field type enums which are extended in fpc fixes, so different that fpc-3.2.2.

So, calebs, if you used the Debian supplied FPC, as has been suggested, you would not have the "db field type enums" problem but it would fix the first problem you had !

(I solemnly promise not to comment on this topic on this thread again!)

Davo
Lazarus 3, Linux (and reluctantly Win10/11, OSX Monterey)
My Project - https://github.com/tomboy-notes/tomboy-ng and my github - https://github.com/davidbannon

cdbc

  • Hero Member
  • *****
  • Posts: 1157
    • http://www.cdbc.dk
Re: Lazarus Release 3.0
« Reply #142 on: January 30, 2024, 12:32:43 pm »
Hi
I think this belongs here...
@dbannon: Davo have you got a running / functioning laz 3.0 with Qt 5? ...and how did you do that?
I'm having some problems with dialogs crashing... Have opened 2 threads in Qt subforum.
Regards Benny
If it ain't broke, don't fix it ;)
PCLinuxOS(rolling release) 64bit -> KDE5 -> FPC 3.2.2 -> Lazarus 2.2.6 up until Jan 2024 from then on it's: KDE5/QT5 -> FPC 3.3.1 -> Lazarus 3.0

calebs

  • Full Member
  • ***
  • Posts: 191
Re: Lazarus Release 3.0
« Reply #143 on: January 30, 2024, 05:20:34 pm »
Sorry, I post it here because this problem was presented with 3.0 version of lazarus and not with previous one.
The fact that i've used fpcupdeluxe or download official packages from website all have problems with modern debian 12 that previous 2.x don't.
I'l try to look that solution but so long everything i tried fail on some step.
About zeos was a commentary about a problem that always appears when fpc changes and zeos refuses to compile (even with the oficial downloaded from online packager).
I'll look up to solve those problems.
Thanks for everything and your time.

....
any recipe to make work zeos out of stable 3.2.2 fpc?

calebs, as TRon suggested, these issues do not belong in the Lazarus 3.0 release thread. Your may have a FPC issue or it may be a Zeos issue, in either case, please post a new message under the appropriate heading. Probably a good idea to look into those error messages too, eg, if something is expecting 7 parameters and something else is offering a number other than 7, have a look at why ? What has changed ? 

Davo

dbannon

  • Hero Member
  • *****
  • Posts: 2842
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Lazarus Release 3.0
« Reply #144 on: January 30, 2024, 11:44:30 pm »

@dbannon: Davo have you got a running / functioning laz 3.0 with Qt 5? ...and how did you do that?
I'm having some problems with dialogs crashing... Have opened 2 threads in Qt subforum.
Regards Benny
Benny, I have released v0.39 of my app, tomboy-ng all built with Lazarus 3.0, That includes a Linux Qt5 and Qt6 version.  And the Qt5 version has been accepted into Debian Testing. I use the Qt5 version on my own Desktop, not had a problem. It does use a file save dialog but not extensively. I don't think it uses a file open dialog.

I will go and read you message in the Qt5 sub forum and respond there.

Davo
Lazarus 3, Linux (and reluctantly Win10/11, OSX Monterey)
My Project - https://github.com/tomboy-notes/tomboy-ng and my github - https://github.com/davidbannon

bpranoto

  • Full Member
  • ***
  • Posts: 142
Re: Lazarus Release 3.0
« Reply #145 on: February 09, 2024, 02:49:57 am »
Linux App generated with lazarus 3.0 flickering when run remotely from windows computer.

Situation:
I have a Linux application generated with Lazarus, the client needs to run the application remotely from windows stations through X2Go.

However, if the app compiled with  lazarus 3.0, it is flickered badly which make it is unusable. There is no problem when the app recompiled with Lazarus 2.2, it runs fine.

In this youtube video: https://youtu.be/CmkvYfERhvw, I made a simple application with a blank form. You can see in the video when I resize the form, the app start flickers make it unusable.

In real application with menu etc, the situation is worse. The app flickers right away after you run it.

I know this is not Lazarus fault (bug) but the fault of the X Server on the client side, however it prevents me to use lazarus 3 for this Client.

Btw I have tried to use different X-Servers: latest VcXSrv and XMing. All suffer the same issue

cdbc

  • Hero Member
  • *****
  • Posts: 1157
    • http://www.cdbc.dk
Re: Lazarus Release 3.0
« Reply #146 on: February 09, 2024, 06:27:39 am »
Hi
Has the clipboard vanished from Lazarus? See: https://forum.lazarus.freepascal.org/index.php?topic=66160.msg505673#msg505673
This thread is about 3.0, isn't it...
Regards Benny
If it ain't broke, don't fix it ;)
PCLinuxOS(rolling release) 64bit -> KDE5 -> FPC 3.2.2 -> Lazarus 2.2.6 up until Jan 2024 from then on it's: KDE5/QT5 -> FPC 3.3.1 -> Lazarus 3.0

Thaddy

  • Hero Member
  • *****
  • Posts: 14560
  • Sensorship about opinions does not belong here.
Re: Lazarus Release 3.0
« Reply #147 on: February 09, 2024, 06:45:33 am »
Linux App generated with lazarus 3.0 flickering when run remotely from windows computer.

Situation:
I have a Linux application generated with Lazarus, the client needs to run the application remotely from windows stations through X2Go.

However, if the app compiled with  lazarus 3.0, it is flickered badly which make it is unusable. There is no problem when the app recompiled with Lazarus 2.2, it runs fine.

In this youtube video: https://youtu.be/CmkvYfERhvw, I made a simple application with a blank form. You can see in the video when I resize the form, the app start flickers make it unusable.

In real application with menu etc, the situation is worse. The app flickers right away after you run it.

I know this is not Lazarus fault (bug) but the fault of the X Server on the client side, however it prevents me to use lazarus 3 for this Client.

Btw I have tried to use different X-Servers: latest VcXSrv and XMing. All suffer the same issue
use native vnc client and servers for both platforms may help. they usually perform better. also note performance may differ between widget sets. in case you use qt swith to gtk2.
also is the linux box running x on top of wayland or plain x.?

I have similar applications running over vnc's .These apps are compiled with Lazarus 3.99 and run on raspberry pi OS on several Raspberry Pi models and have no problems. The client is a VNC client running on Windows 11. They run over 1Gb (local network, also over WIFI 300Mb) and 100Mb (over the internet). Currently X on top of wayland is a little slower, but usually should not matter. (RPi OS runs X on top of wayland on versions >= Rpi4)
« Last Edit: February 09, 2024, 07:05:24 am by Thaddy »
bitrate is always calculated like this:sample rate * bitdepth * number of channels.

99Percent

  • Full Member
  • ***
  • Posts: 160
[solved] Cannot install, missing fpc-laz
« Reply #148 on: February 19, 2024, 09:28:10 pm »
I used to program in lazalus extensively before.

Trying to catch up and recover my IDE again

I am trying to follow the instructions at the wiki: https://wiki.freepascal.org/Installing_Lazarus_on_Linux

Code: Pascal  [Select][+][-]
  1. sudo apt install ./fpc_something.deb ./fpc-src_something.deb ./lazarus-something.deb
or
Code: Pascal  [Select][+][-]
  1. sudo apt install ./fpc-laz_3.2.2-210709_amd64.deb  ./fpc-src_3.2.2-210709_amd64.deb  ./lazarus-project_2.2.0-0_amd64.deb


But I cannot find the fpc-laz files. I remember this wasn't needed before. The Lazarus 3.0 downloaded from sourceforge will not install without it.

ok, I found it again here: https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%203.0/ (do not click on the big big green button  "Download Latest Version", now I really hate the archaic sourceforge)

Edit 2: wrong again, I am getting the "There is already a configuration from version 3.0.0.3" message now. The lazarus-project deb in that page seems to be an outdated RC.

Edit 3: decided to go for the git download route (I am not touching fpcupdeluxe as I just want one solid enviroment.) make command throws a cryptic "can't find unit db used by fcllaz" which after some investigating led me to delete a previously created .fpc.cfg file in my home directory, after which `make bigide` and `sudo make install` worked. lazarus starts but I am having a lot of window composing issues, I think I need to install some gtk libraries for it to work correctly in my debian 12 / regolith3 desktop, but which ones?
« Last Edit: February 20, 2024, 12:58:27 am by 99Percent »

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4479
  • I like bugs.
Re: [solved] Cannot install, missing fpc-laz
« Reply #149 on: February 20, 2024, 07:27:27 am »
I think I need to install some gtk libraries for it to work correctly in my debian 12 / regolith3 desktop, but which ones?
One way to get all needed requirements is to install the Lazarus version from Debian repository. It is an old one.
Then "git clone ..." the Lazarus sources from GitLab, build and start directly from its location "./lazarus &".
The installed version can stay there or you can uninstall it. Makes no difference.
Then you can use the fixes_3_0 branch and pull the latest bug fixes sometimes. You will not be dependent on the releases.
Or you can use the main branch with all its new development. It is very usable most of the time.
« Last Edit: February 21, 2024, 12:30:19 am by JuhaManninen »
Mostly Lazarus trunk and FPC 3.2 on Manjaro Linux 64-bit.

 

TinyPortal © 2005-2018