Forum > General

[Solved] i can't inatall Dam dialog ?!

(1/7) > >>

majid.ebru:
Hi
please help or guide me

i want to insatll dam diaolg https://github.com/digao-dalpiaz/Dam

at fiirst i should install DzHTMLText https://github.com/digao-dalpiaz/DzHTMLText

but aftre i installed DzHTMLText  , my lazarus damaged and didn't run ?

what is run ?

paweld:
Missing the SHcore.dll library on your system. In my case, in Windows 10, it is found in the location: C:Windows32System32SHCore.dll and C:WindowsSysWOW64SHCore.dll.
Check if this library is present on your system.

majid.ebru:
No

Before I installed that component, my Lazarus worked correctly.

But after i installed that  , this DLL file missing

paweld:
Download this library from the Internet, and copy it to the Lazarus directory - make sure that the bit version of the library is compatible with lazarus

Josh:
have you checked the dll exits?
start powershell in administrator rights and enter

--- Code: ---Get-ChildItem c:\windows -include *.dll -recurse | foreach-object { "{0}" -f [System.Diagnostics.FileVersionInfo]::GetVersionInfo($_) } > "$($env:USERPROFILE)\Desktop\DLL_Versions.txt"

--- End code ---

This will create a list of your dll windows knows about and send the output to your desktop in a file called DLLVesions.txt ie

--- Code: ---File:             C:\windows\SysWOW64\SHCore.dll
InternalName:     SHCORE
OriginalFilename: SHCORE.dl
FileVersion:      10.0.22621.2715 (WinBuild.160101.0800)
FileDescription:  SHCORE
Product:          Microsoft® Windows® Operating System
ProductVersion:   10.0.22621.2715
Debug:            False
Patched:          False
PreRelease:       False
PrivateBuild:     False
SpecialBuild:     False
Language:         English (United States)
--- End code ---

It can take a while.. So be patient.

Navigation

[0] Message Index

[#] Next page

Go to full version