Forum > General

Not able to add any component after an application has run

<< < (2/5) > >>

dseligo:
Sometimes I have similar problems with Lazarus 2.2.6 on Windows 11.
It happens only with new projects. After I save project and close Lazarus, and start all again it works fine afterwords.

sfeinst:

--- Quote from: andrew Bubble on December 01, 2023, 08:34:16 pm ---Hi All

An update on the above, I have installed a fresh Raspberry PI OS Bookworm and disabled Wayland as before.

I have installed just Lazarus using the sudo apt install fpc lazarus-ide.

With no install of any extra packages just the components that come with the lazarus ide, I have made a simple application with one button.

If I run this and then stop the application I cannot add another button or any component, same error as before.

I tried closing lazarus and the re starting and this time run the application without debugger, same issue as before.

Any clues anyone

--- End quote ---

I have the same exact problem running Debian Bookworm.  So I do not think this is a Raspberry PI issue.  It is either a Linux issue or more likely a Debian Bookworm issue.  I tried downloading the debs on the Lazarus site and still had an issue.  I have not narrowed down when it occurs.  But it is sometime after running an app and then making component changes (especially changing a controls name or adding an event handler).  I have had it happen immediately and at other times I can run the app multiple times before it occurs.  But I can expect to restart Lazarus many times a day.  I try to make all visual/property changes even if I'm not ready to code.  Save the project.  Then I know I will only have one restart and I can add code and everything is good (until I need another visual change).

My next attempt will be to downloaded sources and build Lazarus, I just haven't had time to do it - need some free ours to test it out.  But the restarts are definitely getting on my nerves which will force me to find time to build from source.

andrew Bubble:
Hi sfeinst

I have not used Ubuntu before but I did a fresh install with Ubuntu on a Raspberry pi 5.

I installed Lazarus as before and I have the same issue on a PI 5 running ubuntu Desktop 23.10.

Regards Andrew

JuhaManninen:

--- Quote from: andrew Bubble on December 01, 2023, 10:13:41 pm ---Thanks for the reply, unfortunately I am not familiar with Linux so much of what you ask for I would not have a clue.

--- End quote ---
$ git clone https://gitlab.com/freepascal.org/lazarus/lazarus.git
$ cd lazarus
$ make
$ ./lazarus &

andrew Bubble:
Hi

Thanks very much I will give that a try

Regards Andrew

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version