Forum > General

Not able to add any component after an application has run

(1/5) > >>

andrew Bubble:
Hi All

Strange issue here, I am using Lazarus version 2.2.6+dfsg2-2 on a Raspberry PI 5 bookworm but with Wayland disabled (issues with extra widgets).

If I make a simple application with say one TButton, I can click on the button and the normal button click procedure appears in the source editor all is ok.

If I then simply run and stop the application, if I add another TButton, this shows on the form but in the source file header only Button1 is shown.

If I click the second button I get the following error.

Unable to create new method, please fix the error shown, the error shown in the Messages is unit1.pas Error unit not found StdCtrls.

If I try to close the application and then open it there appears to be gohst buttons shown on the form.

Only if I shut down Lazarus and launch it again can I open the application.

Regards Andrew

andrew Bubble:
Hi All

An update on the above, I have installed a fresh Raspberry PI OS Bookworm and disabled Wayland as before.

I have installed just Lazarus using the sudo apt install fpc lazarus-ide.

With no install of any extra packages just the components that come with the lazarus ide, I have made a simple application with one button.

If I run this and then stop the application I cannot add another button or any component, same error as before.

I tried closing lazarus and the re starting and this time run the application without debugger, same issue as before.

Any clues anyone

Sounds weird. Maybe the installation packages for Raspberry PI are broken somehow.
I can only recommend to clone Lazarus sources from GitLab and to build them. FPC and other requirements are installed already by your "apt install" efforts.
Just run "make" and then start "./lazarus &" from its source location. No need to install it.
As an extra benefit you get the new fixes_3_0 branch and can later "git pull" latest bug fixes.

andrew Bubble:

Thanks for the reply, unfortunately I am not familiar with Linux so much of what you ask for I would not have a clue.

I do have a PI 4 running bullseye with Lazarus 2.0.10+dfsg+4, this runs without an issue.

As you can see I had an issue when first installing the lazarus and this was a Wayland problem.

Regards Andrew

andrew Bubble:

Just a thought, is there another way to install lzaraus other than the apt-get which I have used in the past.

Regards Andrew


[0] Message Index

[#] Next page

Go to full version