Forum > General

Lazarus IDE: dark theme mode does not work anymore on macOS Sonoma



The dark theme (dark mode) does not work anymore on my Lazarus IDE on macOS x86_64 Sonoma (see image). Also, applications built with such IDE have always the "light theme" even if the OS has the dark theme activated.

Do you know why?

Both Lazarus IDE and applications compiled with it used to be able to go in "dark theme" automatically without the need to do anything. Unfortunatelly, I have recently updated the OS, Xcode and Lazarus, so I don't know what caused this situation.
My current versions:

* macOS Sonoma 14.1.1
* Xcode 15.0.1 (15A507)
* Lazarus 2.2.7 taken from fixes_2_2: (commit ada7a90f86479e4b61da343f58155a7ba4f17ca4 (HEAD -> fixes_2_2, origin/fixes_2_2), Date: Sat Mar 4 14:17:32 2023 +0100)
* Widget: cocoa

This issue has been extensively discussed (and more or less solved) here:,64768.msg501675.html#msg501675

The -WM10.14 option (in both "Configure "Build Lazarus" and "Project Options - Custom Options") worked for me too.

Thank you for letting me know!

Tested on:
Lazarus 3.1 (rev lazarus_3_0-76-g2511674f2d) FPC 3.2.2 aarch64-darwin-cocoa

It works for me too.


[0] Message Index

Go to full version