Forum > Windows (32/64)

[Solved] Unable to install 2.2.6 Win32 cross compiler

(1/2) > >>

Windows 11 22H2

Hi, no issues installing lazarus-2.2.6-fpc-3.2.2-win64.exe, but lazarus-2.2.6-fpc-3.2.2-cross-i386-win32-win64.exe refuses to install - right click > run and run as administrator do nothing.
I've never had previous issues installing earlier versions of Lazarus.

Any advice, please?

Edit :

Try these suggestions:
- move file somewhere outside Downloads directory and try then
- check antivirus if there are messages regarding this file
- check event log around time you try to start installation to see if there are related messages
- try to download file again

I tried running both Lazarus installation and cross compiler installation and they look different on my Windows 11 (I attached screenshots of the first window that shows).
They are different (which suggests that Windows treats them differently).
Also, window that first shows in your Lazarus installation is different than that when starting one in my computer, so that suggests that something is different in my User-Account Control settings from your setting.

Check SmartScreen settings: go to Windows Settings, then "Privacy & Security", "Windows Security", "Open Windows Security".
Go to "App & browser control" on the left side, and below "Reputation-based protection", open "Reputation-based protection settings" and check settings there.

IIRC: Click on the "More info" link => then you get the option to "run anyway"


--- Quote from: Martin_fr on November 20, 2023, 11:19:28 am ---IIRC: Click on the "More info" link => then you get the option to "run anyway"

--- End quote ---

He doesn't get to this window. In post above I took a screenshot how it looks on my computer.


[0] Message Index

[#] Next page

Go to full version