Forum > Embedded - ARM

free pascal pi pico. can't open executable. ( .elf )

(1/2) > >>


first checked this side for this error, but nothing found.

The error just apeared. Checked multiple programms, same error.


Compile Project, Mode: Raspberry Pi Pico, OS: embedded, CPU: arm, Target: C:\Users\cobal\OneDrive\projects Laz Pico\pico-fpcexamples-main\pico-fpcexamples-main\i2c_scan\bin\i2c_scan.elf: Exit code 1, Errors: 1, Hints: 2
Hint: Start of reading config file C:\fpcLaz_Pico\fpc\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file C:\fpcLaz_Pico\fpc\bin\x86_64-win64\fpc.cfg
Verbose: Free Pascal Compiler version 3.3.1-9929-g8d63a1ddfd [2022/01/18] for arm
Verbose: Copyright (c) 1993-2022 by Florian Klaempfl and others
Verbose: Target OS: Embedded
Verbose: Compiling i2c_scan.lpr
Verbose: Assembling i2c_scan
Verbose: Linking C:\Users\cobal\OneDrive\projects Laz Pico\pico-fpcexamples-main\pico-fpcexamples-main\i2c_scan\bin\i2c_scan
i2c_scan.lpr(57,0) Error: Can't open executable "C:\Users\cobal\OneDrive\projects Laz Pico\pico-fpcexamples-main\pico-fpcexamples-main\i2c_scan\bin\i2c_scan.elf"
Verbose: Compilation aborted
Verbose: C:\fpcLaz_Pico\fpc\bin\x86_64-win64\ppcrossarm.exe returned an error exitcode

Things worked before...

Checked the directory:

Tnx in advance! Marcel

Does it work when you (cross) compile on a local drive ?

Verbose: Free Pascal Compiler version 3.3.1-9929-g8d63a1ddfd [2022/01/18] for arm

It is too old 3.3, it's better to update to last Git version.

I've seen the compiler write this: "Can't open executable", before...
It was when I accidently had the app running for test in a console-window, so it was locked for the compiler to write to...
Could that be it?
Regards Benny

There are actually two separate sins:
- compiling on a 3th party (external) filesystem
- using spaces in a project name/path

Something to do with reaping and sowing if I remember correctly  :)


[0] Message Index

[#] Next page

Go to full version