Forum > Editor

My Key Mapping doesn't work any more


After downloading the anchordocingdsgn 1.0 package I realised that my key mapping [Ctrl+`] doesn't work any more. I use this to go to my source editor without having to use my mouse. Is it a bug or is it something configurable?

First of all, check that it is still assigned (in Tools > Editor > Keymap). Maybe something else got put in place...

Second: Your OS, and Lazarus version?

Third: I have see occasional issues with keys not working as expected under anchordocking. but I am uncertain what exactly the issue is (iirc there are some issues on the bug tracker).
- Try to assign to another key combo
- Check if it is certain other Windows (or controls/edit/input...) that block this from working.

It could also be, that the key is working, but focus isn't correctly set.... (would the key combo open the search dlg, if that was assigned?)

When you say AnchorDocking: That is just Anchordocking[Dsgn]? (maybe including DockedFormEditor).
But it does not include anything with "Sparta" in the name? Those "Sparta" package are broken. Don't use them.

I am using Windows 10, Lazarus version 2.2.6 and the package is ancordocingdsgn 1.0 only.
The key mapping is there but when I use it, it doesn't work. When I uninstall the package it works fine. I've also tried other key combinations without any success. Rebuild doesn't do anything either.

Then it sound like a bug in Anchordocking.

I've also tried to navigate to the source editor via Alt-V using the down arrow to source editor, pressed enter but nothing, not even that. Anyway I'll play with it, if I find a solution I'll post it here.


[0] Message Index

Go to full version