Recent

Author Topic: Error in Sway  (Read 595 times)

AlexTP

  • Hero Member
  • *****
  • Posts: 2233
    • UVviewsoft
Error in Sway
« on: May 31, 2023, 02:45:20 pm »
There's this error on gtk2-app startup when run on the latest Fedora Sway.
Sway is a Wayland compositor/window manager.

Code: Pascal  [Select][+][-]
  1. [user@pc ~]$ cudatext
  2.  
  3. (cudatext:2440): Gtk-CRITICAL **: 12:50:03.417: IA__gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed
  4.  
  5. (cudatext:2440): Gtk-CRITICAL **: 12:50:03.417: IA__gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

AmatCoder

  • Jr. Member
  • **
  • Posts: 50
    • My site
Re: Error in Sway
« Reply #1 on: May 31, 2023, 04:02:28 pm »
GTK2 apps don't support Wayland.
They should use the X server that is provided by XWayland.


1) Do you have installed XWayland? AFAIK Fedora split XWayland into its own standalone package.

2) Have you disable Xwayland on Sway?

3) Have you set the GDK_BACKEND environment variable? Forcing `GDK_BACKEND=wayland` in the environment is a bad idea.

AlexTP

  • Hero Member
  • *****
  • Posts: 2233
    • UVviewsoft
Re: Error in Sway
« Reply #2 on: June 01, 2023, 02:02:39 pm »
@AmatCoder
1) "Package "xorg-x11-server-Xwayland-22.1.9-2.fc38.x86_64" is already installed."

2) No

3) No

Bad Sector

  • Jr. Member
  • **
  • Posts: 68
    • Runtime Terror
Re: Error in Sway
« Reply #3 on: June 06, 2023, 02:41:49 pm »
There's this error on gtk2-app startup when run on the latest Fedora Sway.
Sway is a Wayland compositor/window manager.

Code: Pascal  [Select][+][-]
  1. [user@pc ~]$ cudatext
  2.  
  3. (cudatext:2440): Gtk-CRITICAL **: 12:50:03.417: IA__gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed
  4.  
  5. (cudatext:2440): Gtk-CRITICAL **: 12:50:03.417: IA__gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

These seem to be LCL gtk2 backend issues caused by using an invalid (most likely freed) widget, so try to build LCL and the application with full debug symbols and then run it with

Code: [Select]
$ G_DEBUG=fatal-criticals gdb ./cudatext

This will cause a break when the first Gtk-CRITICAL assertion is found so then you can use the bt command in gdb to get the callstack which will tell you exactly where LCL makes the call with the invalid widget.
Kostas "Bad Sector" Michalopoulos
Runtime Terror

 

TinyPortal © 2005-2018