Author Topic: [SOLVED] LAMW: Cannot build empty project  (Read 256 times)


  • New Member
  • *
  • Posts: 10
[SOLVED] LAMW: Cannot build empty project
« on: May 26, 2023, 07:59:50 am »
Hi all

It's the first time I try LAMW.
I've used provided script to install LAMW. Everything seem went fine, all dependencies install, Lazarus + FPC is built.
However, when I try to build for Arm v7 (Run-[LAMW] Build Android Apk and Run) and just get following in "Message" window:

Code: [Select]
Verbose: Selected chip architecture: armeabi-v7a
Verbose: Taking libraries from folder: /home/denis/Dev/LAMWProjects/LucidLite/libs/armeabi-v7a
Compile package FCL 1.0.1: Exit code 1, Errors: 1
Fatal: Cannot find system used by fcllaz of package FCL.
Looks like some packages do not have arm builds.

Also I have following error shown when I start Lazarus:

Code: [Select]
The project uses target OS=android and CPU=arm.
The system.ppu for this target was not found in the FPC binary directories.
Make sure fpc is installed correctly for this target and the fpc.cfg contains the right directories.

Console shows following output on trying to build project:
Code: [Select]
Hint: (lazarus) [TBuildManager.SetBuildTarget] Old=x86_64-linux-gtk2 New=arm-android-gtk2 Changed: OS/CPU=True LCL=False
Hint: (lazarus) Last compile was incomplete for FCL 1.0.1
  State file="/home/denis/LAMW/lamw4linux/lazarus_stable_git/packager/units/arm-android/FCL.compiled"
Hint: (lazarus) Missing state file of LazUtils 1.0: /home/denis/LAMW/lamw4linux/lazarus_stable_git/components/lazutils/lib/arm-android/LazUtils.compiled
Hint: (lazarus) Missing state file of LCLBase 2.0.12: /home/denis/LAMW/lamw4linux/lazarus_stable_git/lcl/units/arm-android/LCLBase.compiled
Hint: (lazarus) Missing state file of tfpandroidbridge_pack 0.0: /home/denis/LAMW/lazandroidmodulewizard/android_bridges/lib/arm-android/tfpandroidbridge_pack.compiled
Info: (lazarus) Execute Title="Compile package FCL 1.0.1"
Info: (lazarus) Working Directory="/home/denis/LAMW/lamw4linux/lazarus_stable_git/packager/registration/"
Info: (lazarus) Executable="/home/denis/LAMW/lamw4linux/usr/bin/fpc"
Info: (lazarus) Param[0]="-Tandroid"
Info: (lazarus) Param[1]="-Parm"
Info: (lazarus) Param[2]="-MObjFPC"
Info: (lazarus) Param[3]="-Scghi"
Info: (lazarus) Param[4]="-O1"
Info: (lazarus) Param[5]="-g"
Info: (lazarus) Param[6]="-gl"
Info: (lazarus) Param[7]="-l"
Info: (lazarus) Param[8]="-vewnhibq"
Info: (lazarus) Param[9]="-Fu/home/denis/LAMW/lamw4linux/lazarus_stable_git/packager/registration/"
Info: (lazarus) Param[10]="-FU/home/denis/LAMW/lamw4linux/lazarus_stable_git/packager/units/arm-android/"
Info: (lazarus) Param[11]="fcllaz.pas"
TIDEFPCParser.ImproveMsgUnitNotFound FindUnitInAllUsesSections failed due to syntax errors or system is not used in /home/denis/LAMW/lamw4linux/lazarus_stable_git/packager/registration/fcllaz.pas
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
Error: (lazarus) [TMainIDE.DoBuildProject] PkgBoss.DoCompileProjectDependencies failed

Could anyone provide some hints on how to fix that?

It appeared I had old FPC installed in another directory and it took precedence over LAMW.
As soon as I removed it build went fine.
Sorry for noise.

« Last Edit: May 26, 2023, 09:17:17 am by MageSlayer »


  • Newbie
  • Posts: 2
Re: [SOLVED] LAMW: Cannot build empty project
« Reply #1 on: May 26, 2023, 04:01:18 pm »
It's wrong, by default projects are created to run in ARMV7+fpv3, but apparently you used armv7+soft
There are no indications that there is anything wrong with your installation unless you have done so (edited files you didn't need)
« Last Edit: May 27, 2023, 12:04:51 am by nobody.00 »


TinyPortal © 2005-2018