Recent

Author Topic: LAMW - How to build kitkat android using ant?  (Read 374 times)

Mongkey

  • Sr. Member
  • ****
  • Posts: 331
LAMW - How to build kitkat android using ant?
« on: May 26, 2023, 05:43:13 am »
i've been struggling build an apk in kitkat, but it seems fail, any body know how to do? ant always give error build

Progress:     [javac] error: Source option 5 is no longer supported. Use 7 or later.
Progress:     [javac] error: Target option 5 is no longer supported. Use 7 or later.
Progress:
Progress: BUILD FAILED

Thank you

jmpessoa

  • Hero Member
  • *****
  • Posts: 2208
Re: LAMW - How to build kitkat android using ant?
« Reply #1 on: May 26, 2023, 06:55:33 am »

Are you using "old" java sdk?
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Mongkey

  • Sr. Member
  • ****
  • Posts: 331
Re: LAMW - How to build kitkat android using ant?
« Reply #2 on: May 26, 2023, 12:21:57 pm »
I used latest adoptium java SDK mr. JP, do we need to use old java SDK?
or got any setting for ant?

Thank you.
« Last Edit: May 26, 2023, 12:23:49 pm by Mongkey »

jmpessoa

  • Hero Member
  • *****
  • Posts: 2208
Re: LAMW - How to build kitkat android using ant?
« Reply #3 on: May 27, 2023, 12:39:35 am »

My JDK: 
Code: Pascal  [Select][+][-]
  1. C:\Program Files\Java\jdk1.8.0_151
  2.  

Quote
or got any setting for ant?

No.
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

 

TinyPortal © 2005-2018