Forum > LCL

pl_SynapseVS in error

(1/1)

folkeu08:
Hi,
On the release 2.2.6 of lazarus with the Online Package Manager and manualy, the set of components pl_SynapseVS are on error with a function.
is it normal even though it is rated & ok and tested for installation ?
Thanks
Fran├žois

rvk:

--- Quote from: folkeu08 on May 07, 2023, 04:15:44 pm ---is it normal even though it is rated & ok and tested for installation ?

--- End quote ---
What makes you think it is rated & ok and tested?

It probably works for an older version of Lazarus.
Ask the maintainer to fix the issue.

(You also don't mention what error in what file so nobody can help you here.)

GetMem:
@folkeu08

--- Quote ---is it normal even though it is rated & ok and tested for installation ?
--- End quote ---
Yes it's perfectly normal. I fixed the package in OPM. Please do the following.
1. Click the "Local repo" button(see attached image)
2. Delete synapse 40.1 folder
3. Close, reopen IDE
4. Install pl_synapseVS from OPM again

@avra
I attach the fixed unit pl_synapsevs\source\vsrawip.pas so you can update your repo. If you wish to switch back to the old version, just let me know.

Navigation

[0] Message Index

Go to full version