Recent

Author Topic: lazarus won't start  (Read 22867 times)

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Re: lazarus won't start
« Reply #15 on: March 03, 2009, 10:51:42 am »
Nice that you got things working.

I thought that $HOME/fpc.cfg had to be moved to $HOME/.fpc.cfg to let the compiler find it, but maybe I am wrong.

Triple

  • New Member
  • *
  • Posts: 20
Re: lazarus won't start
« Reply #16 on: March 03, 2009, 11:03:38 am »
Hi,

after downloading the binary package the script install a fpc.cfg inside the $HOME only for the temp use of the fpc inside $HOME/fpc/bin .

But this configuration file could make problems after installing the new fpc .

Maybe problems, becouse of old path things and so on. So therefore a new fpc.cfg will be generated from the new fpc build

I used the $HOME for the first cfg because of the write permissons  but after installing the builded fpc its good to store the cfg inside /etc so every user have acess to


regards Martin
« Last Edit: March 03, 2009, 03:40:45 pm by Triple »

Triple

  • New Member
  • *
  • Posts: 20
Re: lazarus won't start
« Reply #17 on: March 03, 2009, 11:13:37 pm »
So now we are going to build Lazarus  :)

first of all make shure that you have following packages proper installed
Code: [Select]
x11proto-kb-dev install
libxdmcp-dev install
xtrans-dev install
x11proto-core-dev install
x11proto-input-dev install
libpthread-stubs0-dev install
libxau-dev install
libpthread-stubs0 install
libx11-dev install
libxcb-xlib0-dev install
libxcb1-dev install
libglib1.2ldbl install
libgtk1.2 install
libgdk-pixbuf2 install
libgtk1.2-common install
libstdc++6-4.3-dev install
libsm-dev install
libuser-identity-perl install
libice-dev install
x11proto-xext-dev install
libatk1.0-dev install
debhelper install
intltool-debian install
libglib2.0-dev install
libmime-types-perl install
x11proto-xinerama-dev install
libpango1.0-dev install
g++-4.3 install
x11proto-render-dev install
libglib1.2-dev install
libxi-dev install
libxrender-dev install
po-debconf install
libcairo2-dev install
libfile-remove-perl install
libsysfs-dev install
g++ install
libpng12-dev install
libfontconfig1-dev install
libmail-sendmail-perl install
libdirectfb-dev install
x11proto-composite-dev install
libxcursor-dev install
gettext install
x11proto-randr-dev install
x11proto-damage-dev install
libio-stringy-perl install
libxcb-render-util0-dev install
libgtk2.0-dev install
libxext-dev install
libjpeg62-dev install
libxdamage-dev install
libobject-realize-later-perl install
zlib1g-dev install
libfreetype6-dev install
x11proto-fixes-dev install
dpkg-dev install
libgtk1.2-dev install
libxcomposite-dev install
libmpeg3-dev install
libxrandr-dev install
libexpat1-dev install
html2text install
libpixman-1-dev install
libxft-dev install
libdigest-hmac-perl install
libxcb-render0-dev install
libxfixes-dev install
libxinerama-dev install
libmail-box-perl install
libsys-hostname-long-perl install
libmpeg3-1 install
libdigest-sha1-perl install
build-essential install
libgdk-pixbuf-dev install
glibc-source install

These packages  looks like that they are needed from the build process. If you find out some were to much so please tell it here so we can update the list for wiki.

To make it easy as much as possible you can safe this into a file name it install_all.txt open synaptics . There you can import the file.

After this  you can start the following script

Code: [Select]
#! /bin/bash
#save this file as get_lazarus_svn.sh & store it @$HOME
#set -x
#
svn checkout http://svn.freepascal.org/svn/lazarus/trunk/ $HOME/lazarus/svn
cd $HOME/lazarus/svn
make
#
# http://wiki.lazarus.freepascal.org/Installing_Lazarus/de
#
echo "use <svn update lazarus> inside $HOME/lazarus/svn 4 update Lazarus svn"
exit -a


Now the build process should run through


This was now done by me on a new fresh debian5 system with Powerpc architekture. Maybe some packages where to much but this list was created by try and error to get the build process run through.

Hope this will help some people to climb over the first hill building Lazarus and get it working.

So have fun

I tried this out . Yet you got Revision 18887. But building an error occur

Compiling allsyneditunits.pp
Compiling synpropertyeditobjectlist.pas
Fatal: Can't find unit PropEdits used by SynPropertyEditObjectList
Fatal: Compilation aborted
make[2]: *** [allsyneditunits.ppu] Fehler 1
make[2]: Leaving directory `/home/martin/lazarus/svn/components/synedit'
make[1]: *** [synedit_all] Fehler 2
make[1]: Leaving directory `/home/martin/lazarus/svn/components'
make: *** [components] Fehler 2

This looks like a problem from the source today.


Martin
« Last Edit: March 03, 2009, 11:24:51 pm by Triple »

Leledumbo

  • Hero Member
  • *****
  • Posts: 8273
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: lazarus won't start
« Reply #18 on: March 04, 2009, 05:37:11 am »
I just got the same error with the latest daily snapshot. The build order seems wrong because SynEdit gets built before IDEIntf does. I solve this problem by doing 'make all' in ideintf folder first, then continue the broken 'make all' from the top directory. No bug report about this yet AFAIK, so please make it (I'm too lazy to do it :D). Note that this bug doesn't occur if you build lazarus from the IDE (don't know why).

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Re: lazarus won't start
« Reply #19 on: March 04, 2009, 08:22:09 am »
This error is suposedly fixed in r18888: http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=18888

Instead of make (or make all), I would advice make bigide, which adds some more components to the component palette. This make target is used in releases and snapshots too.

I use make all for normal development of lazarus itself, it is faster and the binary is smaller.

Triple

  • New Member
  • *
  • Posts: 20
Re: lazarus won't start
« Reply #20 on: March 04, 2009, 09:35:50 am »
Yes now this bug is fixed and it compiles Lazarus completely.

@Leledumbo   No Bug report is neeeded I am also partly lazy  ;)

@Vincent  So the things I have done (scripts) hopefully helps the beginners to startup the wole stuff. Do you think I should write a litte explanation file for it about whats going on ? So this could help a lot to understand whats going on.
We could also modify the script about what's to checkout e.g brunch or trunk or last stable release or something like "get_lazarus stable" or so.


Martin

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Re: lazarus won't start
« Reply #21 on: March 04, 2009, 10:09:12 am »
Martin, I have no opinion about that, but more documentation never hurts, I guess.

That being said, your scripts already have some documentation.

 

TinyPortal © 2005-2018