Recent

Author Topic: How to properly install Lazarus 2.0.12 on Ubuntu LTS to avoid libQt5Pas problems  (Read 422 times)

Kepsz

  • New Member
  • *
  • Posts: 25
Hi,

I'm trying to cross-compile an application from Linux to RaspberryPI, so I can only use the QT5 widget set. But both Ubuntu 22.04 LTS and the Raspberry has the quite old libQt5Pas 1.2.6 package and that is not fully compatible with Lazarus 2.2 (for example, ZeosDBO from OPM will not be able to build).

It is possible to manualy upgrade libQt5Pas to the actual version, but that's not a simple thing to do and it would be needed on Raspberry also. https://wiki.lazarus.freepascal.org/Qt5_Interface https://forum.lazarus.freepascal.org/index.php/topic,54010.0.html So I would like to avoid this if there is an other way.

So I installed the older .deb packages from here https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%202.0.12/, to work with the older libQt5Pas.
Now I have Lazarus 2.0.12 with the default GTK2 widget set. But I was unable to re-compile the IDE to use QT5 widget set.

There are some "Panic" Permission denied messageas about folder access / creation in:
/usr/share/lazarus/2.0.12/ide
../units/x86_64-linux/qt5

I do not know how to proceed further.

Kepsz

  • New Member
  • *
  • Posts: 25
Instead of the old Lazarus install, I installed Ubuntu 22.10 on Raspberry, and turend it to lightweight Lubuntu manualy. This way I have the same libQt5Pas on both Rpi and desktop. So this topic is kinda solved.

 

TinyPortal © 2005-2018