Forum > General

FLT STACK CHECK error under Lazarus IDE 2.2.4


Dear All,
I have programmed a DLL in C that calculates 1 dimensional algebraic functions (just like you would interactively do with the Windows calculator app). This worked fine under Lazarus IDE 2.0.10. Now that I have changed to Lazarus IDE 2.2.4 a runtime error pops up (see attached screenshot). What could be the reason for that? I would be grateful for any feedback.


   The stack overflowed or underflowed as the result of a floating-point operation.
--- End quote ---

I don't know why it didn't happen with the hold setup you had. But often this is a case of being lucky or unlucky. That is some bugs, albeit being present, do not cause an error. But any change in code, may just shift the address that they access, and make them crash.

As a first step ensure you compile
- without optimization
- with debug checks enabled (range, overflow, stack, ....)

Thanks for your reply. I rechecked my codes and adopted some parts. It now works. The old code had worked for me for years in the C environment ;-)


[0] Message Index

Go to full version