Recent

Author Topic: LazBarCode Can't compile  (Read 369 times)

eldonfsr

  • Sr. Member
  • ****
  • Posts: 360
LazBarCode Can't compile
« on: February 01, 2023, 10:19:40 pm »
I tried to install lazbarcode but sent me a error  some body knew about this wo can help me..

ubarcodes.pas(64,14) Error: Identifier not found "PZintSymbol"
ubarcodes.pas(64,25) Error: Error in type definition
ubarcodes.pas(213,27) Error: Identifier not found "PZintRenderLine"
ubarcodes.pas(219,82) Error: Identifier not found "PZintRenderline"
ubarcodes.pas(220,75) Error: Identifier not found "PZintRenderLine"

I using laarus 2.2.4 windows 10...




wp

  • Hero Member
  • *****
  • Posts: 10667
Re: LazBarCode Can't compile
« Reply #1 on: February 02, 2023, 12:21:32 am »
I can confirm it when I install it from OPM, but I don't see it when I install it from my local directory...

The reason probably is that you - like me - always have the same directory into which OPM installs the LazBarcodes package. Version 2 of LazBarcodes, however, made a major reorganisation of files. When you install into the same directory the old files are still there. And this way the second package found some source files which it should not see and tried to compile them, and this must fail because one package is not allowed to find the source files of the other packages.

Solution: Delete the folder into which OPM unzipped the LazBarcode files. Then try to install from OPM again.

eldonfsr

  • Sr. Member
  • ****
  • Posts: 360
Re: LazBarCode Can't compile
« Reply #2 on: February 04, 2023, 02:02:46 am »
yes i delete folder where was installed package and then let me to install new package of lazbarcode....

Thanks......

 

TinyPortal © 2005-2018