Recent

Author Topic: May be an fpc issue  (Read 348 times)

Curt Carpenter

  • Sr. Member
  • ****
  • Posts: 341
May be an fpc issue
« on: June 07, 2023, 09:52:49 pm »
I recently used fpcupdeluxe to install lazarus 2.2.6  and fpc 3.2.2 (version 0df754a22)  on a usb drive.  No problems with the installation.  I was unable to install the Online package Manager though, getting multiple errors that prevented compilation  (eg. clocale.ppu cannot be found, then with that corrected gtkLDisableLibOverlay cannot be found).

Overcame this by deleting fpc 3.2.2 (version 0df754a22) that fpcupdeluxe had installed on my usb drive and replaced it with fpc verion "Revision: unversioned directory" (not sure what that means) from the Lazarus2.2.4/fpc3.2.2 installed on my PC.  It seems to have fixed the problem, with OPM now installed.  I thought I should alert the heroic OPM maintainer to the problem in case it was something new.  It seems to me that there are two different versions of fpc 3.2.2 in use out there.

 

TinyPortal © 2005-2018