Recent

Author Topic: installing fpcdeluxe trunk  (Read 285 times)

alaa123456789

  • Full Member
  • ***
  • Posts: 235
  • Try your Best to learn & help others
    • youtube:
installing fpcdeluxe trunk
« on: January 19, 2023, 06:30:46 pm »
hello ,
i have used fpcdeluxe to install trunk copy of lazarus it is installed , but when i try to install any package
i get these error messages
Quote
Compile package lazparadox 0.0: Exit code 1, Errors: 1, Hints: 2
Hint: Start of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Verbose: Free Pascal Compiler version 3.3.1-12345-g06a7610a35 [2023/01/19] for x86_64
Verbose: Copyright (c) 1993-2023 by Florian Klaempfl and others
Verbose: Target OS: Win64 for x64
Verbose: Compiling lazparadox.pas
Verbose: Compiling regparadox.pp
regparadox.pp(19,65) Error: Cannot find paradox used by regparadox of package lazparadox.
Verbose: Compilation aborted
Verbose: C:\lazarus\fpc\bin\x86_64-win64\ppcx64.exe returned an error exitcode
Compile package OnlinePackageManager 1.0.1.2: Aborted, Warnings: 1, Hints: 2
Hint: Start of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Verbose: Free Pascal Compiler version 3.3.1-12345-g06a7610a35 [2023/01/19] for x86_64
Verbose: Copyright (c) 1993-2023 by Florian Klaempfl and others
Verbose: Target OS: Win64 for x64
Verbose: Compiling onlinepackagemanager.pas
Verbose: Compiling onlinepackagemanagerintf.pas
Verbose: Compiling opkman_const.pas
Verbose: Writing Resource String Table file: opkman_const.rsj
Verbose: Compiling opkman_mainfrm.pas
Verbose: Compiling opkman_downloader.pas
Verbose: Compiling opkman_common.pas
Verbose: Compiling opkman_options.pas
Verbose: Compiling opkman_serializablepackages.pas
opkman_serializablepackages.pas(1572,5) Warning: Case statement does not handle all possible cases
please advise
thanks

dsiders

  • Hero Member
  • *****
  • Posts: 748
Re: installing fpcdeluxe trunk
« Reply #1 on: January 19, 2023, 07:33:43 pm »
hello ,
i have used fpcdeluxe to install trunk copy of lazarus it is installed , but when i try to install any package
i get these error messages
Quote
Compile package lazparadox 0.0: Exit code 1, Errors: 1, Hints: 2
Hint: Start of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Verbose: Free Pascal Compiler version 3.3.1-12345-g06a7610a35 [2023/01/19] for x86_64
Verbose: Copyright (c) 1993-2023 by Florian Klaempfl and others
Verbose: Target OS: Win64 for x64
Verbose: Compiling lazparadox.pas
Verbose: Compiling regparadox.pp
regparadox.pp(19,65) Error: Cannot find paradox used by regparadox of package lazparadox.
Verbose: Compilation aborted
Verbose: C:\lazarus\fpc\bin\x86_64-win64\ppcx64.exe returned an error exitcode
Compile package OnlinePackageManager 1.0.1.2: Aborted, Warnings: 1, Hints: 2
Hint: Start of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file C:\lazarus\fpc\bin\x86_64-win64\fpc.cfg
Verbose: Free Pascal Compiler version 3.3.1-12345-g06a7610a35 [2023/01/19] for x86_64
Verbose: Copyright (c) 1993-2023 by Florian Klaempfl and others
Verbose: Target OS: Win64 for x64
Verbose: Compiling onlinepackagemanager.pas
Verbose: Compiling onlinepackagemanagerintf.pas
Verbose: Compiling opkman_const.pas
Verbose: Writing Resource String Table file: opkman_const.rsj
Verbose: Compiling opkman_mainfrm.pas
Verbose: Compiling opkman_downloader.pas
Verbose: Compiling opkman_common.pas
Verbose: Compiling opkman_options.pas
Verbose: Compiling opkman_serializablepackages.pas
opkman_serializablepackages.pas(1572,5) Warning: Case statement does not handle all possible cases
please advise
thanks

None of those are error messages.
Preview Lazarus 2.3.0 documentation at: https://dsiders.gitlab.io/lazdocsnext

PascalDragon

  • Hero Member
  • *****
  • Posts: 4872
  • Compiler Developer
Re: installing fpcdeluxe trunk
« Reply #2 on: January 19, 2023, 09:45:30 pm »
None of those are error messages.

One of them is:

Code: [Select]
regparadox.pp(19,65) Error: Cannot find paradox used by regparadox of package lazparadox.

dsiders

  • Hero Member
  • *****
  • Posts: 748
Re: installing fpcdeluxe trunk
« Reply #3 on: January 19, 2023, 10:47:06 pm »
None of those are error messages.

One of them is:

Code: [Select]
regparadox.pp(19,65) Error: Cannot find paradox used by regparadox of package lazparadox.

Oops. I need new glasses.
Preview Lazarus 2.3.0 documentation at: https://dsiders.gitlab.io/lazdocsnext

 

TinyPortal © 2005-2018