Forum > Linux

External: SIGSEGV

(1/2) > >>

I am using Lazarus 2.2.4, FPC 3.2.2 on X86-64-linux-gtk2

Every time I try to change the caption on any object, I have tried TEdit, TStaticText and TButton, I get a External: SIGSEGV.  I can change the colour with no problem but if I try  other properties such as top, width, left, etc, I get the same error.

Objects are located on a TForm.


I'm using the same, and don't see anything like that.

Are you doing something like trying to make the change from a background thread without using Synchronize()?

Where did you get your FPC+Lazarus: the official repositories or from whichever distro you're using?

Apart from that I think we really need to see a cut-down project that we can run to try to duplicate the problem.


I had that problem once when I accidently f*cked up some rtl units (importing a project overwrote my default unit path)

Start the ide from a terminal/console (use the command startlazarus) => see if it prints anything when the error happens (if lucky it will print a stack trace)

Do a clean rebuild of the IDE.

Tools > Configure Build lazarus
Select the "clean all" radio

Curious thing happened.  I created a test app and duplicated what I had before and I don't get that problem in my test app.  I have restarted my app and so far all seems Ok.  I must have done something wrong the first time.

Thanks for your comments.


[0] Message Index

[#] Next page

Go to full version