Forum > Linux

The window frame appears for a second at startup and disappears

<< < (2/3) > >>

zeljko:

--- Quote from: Helltar on December 04, 2022, 01:11:46 am ---Here is a screencast, it will be clearer:

https://youtu.be/cONZ5jnjIeU

I do not understand why this is happening.

Lazarus 2.2.4 Qt

--- End quote ---

I guess it's some slow machine, add -disableaccurateframe to your program cmd line.  Same cmdline param applies to all X11 widgetsets (gtk2, qt, qt5 and qt6)

MarkMLl:
I don't see that behaviour when starting a program using Dolphin on KDE even with e relatively slow machine.

MarkMLl

Helltar:

--- Quote ---Sorry, I don't click on random links, especially from a first poster.  Show the code, ideally a simplified version of it.
--- End quote ---

Yes, I understand, but it's just YouTube, I just don't know how to describe it in words.

On the video is clean form (Hello World), but it window is also present in my projects, at first I thought it was something on my part, but probably not.


--- Quote ---I /think/ it's some version of Linux running KDE, hence is possibly germane to the problems in Gus's thread.
--- End quote ---

About KDE, the same thing happens on GNOME (Ubuntu).


--- Quote ---I guess it's some slow machine, add -disableaccurateframe to your program cmd line.  Same cmdline param applies to all X11 widgetsets (gtk2, qt, qt5 and qt6)
--- End quote ---

Thanks, I'll look. No, machine is fine, 16 ram ssd i5.

Today I checked on gtk2, there is no such thing, most likely it is because of Qt.

Here are my programs built with Qt interface, everywhere the same window at startup that appears for half a second.

- https://github.com/Helltar/AMPASIDE
- https://github.com/Helltar/plainotepad
- https://github.com/Helltar/gcencryptor

I use Arch Linux, qt library of this version:

- https://archlinux.org/packages/community/x86_64/qt5pas

Lazarus 2.2.4:

- https://archlinux.org/packages/community/x86_64/lazarus-qt5/

Helltar:

--- Quote from: zeljko on December 04, 2022, 10:59:16 am ---
--- Quote from: Helltar on December 04, 2022, 01:11:46 am ---Here is a screencast, it will be clearer:

https://youtu.be/cONZ5jnjIeU

I do not understand why this is happening.

Lazarus 2.2.4 Qt

--- End quote ---

I guess it's some slow machine, add -disableaccurateframe to your program cmd line.  Same cmdline param applies to all X11 widgetsets (gtk2, qt, qt5 and qt6)

--- End quote ---

Thank you! That helped.

https://wiki.freepascal.org/Lazarus_2.2.0_release_notes#Widgetsets


--- Quote ---Qt, Qt5 and Gtk2: Form dimensions are accurate now on x11 (frame around form).
Solution is provided by creating dummy widget before Application.MainForm.Handle is created. This can be disabled via command line switch "-disableaccurateframe". This feature is used inside WidgetSet.GetWindowRect() only.
--- End quote ---

MarkMLl:
Arch is, of course, well-respected but there's always a chance that they've done something odd when building the package: pulled a not-quite stable one from the official repository etc.

Apropos your initial youtu.be posting, you should be aware that there have been multiple cases of malware embedded in YouTube videos. A text description possibly supported with a screenshot would have been far more welcome.

MarkMLl

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version