Forum > General

Has anyone upgraded to Ubuntu 22.10 and began having issues with IDE?

(1/4) > >>

Gustavo 'Gus' Carreno:
Hey there Y'all,

Has anyone upgraded to Ubuntu 22.10 and been having issues with the IDE?

Ubuntu 22.10 is now using GNOME 43 and I had no issues using the IDE before I upgraded and now both Lazarus 2.2.2 and 2.3 are giving me grief on the Object Inspector and the Form Editor.

I even re-compiled both those versions after I upgraded so they were linked with the newest of the libs...

Funny thing is, that a very old and never re-compiled Lazarus 2.0.12 is working fine... Rather a strange conundrum, no?

I will appreciate any insight, be it as wild as you can think of, cuz at the moment I'm baffled why the IDE misbehaves under Ubuntu 22.10 with GNOME 43!!


Giving you grief HOW exactly? Is this gtk2 or an attempt at 3? Have you tried rebuilding for Qt5?

I moved onto the "Testing" ("Bookworm") version of Debian a few weeks ago, and have seen no obvious new problems. An existing problem which persists in places is filenames in dialog(u)e boxes which appear blank until clicked on, a related problem in listboxes was fixed by a late fix to the gtk2 libraries.


Gus, personally I would not use any of the short life Ubuntu's, by time you have it working as expected, its time to update again. But I have also seen a few teething problems in such releases that indicates to me they are often built on a "wonder if this will work ?" basis.

The long term releases seem to have less updates in the weeks after release too. I am about to update to 22.04 now that I know I can strip out all the silly snaps.

But, as I have a recent U2210 VM on hand for testing my app, I just put Lazarus on, my model is usually toe install FPC and FPC-Source from the official repo and install Lazarus from source. All worked well as far as I can see. Just what grief are you being given ?

EDIT: And what Desktop ?


I upgraded my Ubuntu Mate to 22.10 and had been using it for several weeks. I reinstalled my system back to version 22.04 because it crashed too often with my DLink wifi.

I was busy so I only occasionally run Lazarus on Ubuntu 22.10. I didn't notice any issue running Lazarus 2.3.0 on Ubuntu Mate 22.10.

--- Quote from: Gustavo 'Gus' Carreno on November 27, 2022, 08:06:17 am ---Ubuntu 22.10 is now using GNOME 43 and I had no issues using the IDE before I upgraded and now both Lazarus 2.2.2 and 2.3 are giving me grief on the Object Inspector and the Form Editor.

--- End quote ---

What was the issue? Can you provide some screenshots?

Ubuntu Mate uses Mate Desktop, which is based on GNOME 2. Maybe that's why I did not experience the problem you're having.

Gustavo 'Gus' Carreno:
Hey Y'all,

Sorry I wasn't more specific on the details of the misbehaving edits on the Object Inspector and having objects like the Main Menu and the Action List not show on the Form Editor

I mainly opted not to enter specifics because it's not something I can screenshot.
But I'll give it a go at explaining it, maybe I can paint a good picture.

Mostly what I've noticed is that after a while, because this issue does not start right after opening, of using the TEdits on the Object Inspector the cursor gets stuck on that particular TEdit.
Well, that's what it feels like because any typing on that TEdit produces nothing.
But if you use the Vertical Scroll bar and push up and down, then the TEdit gets unstuck, and all your typing is shown.
So that's what happens on the TEdits of the Object Inspector.

With the Form Editor, it's mainly the fact that the type of objects that don't have a GUI element, like the main menu icon and the task list icon, they just don't show.

And my system is the new Ubuntu 22.10 that is now using GNOME 43. I really don't know if GTK2 is still supported, or fully supported under GNOME 43!!!
I'm not even sure if recompiling Lazarus makes it a GTK3-4-5 or a GTK2.
I'm sorry I'll have to plea ignorance on this.

But what I do know is that Lazarus 2.0.12, has no issues. And that version is very old in terms of technology months... Right?

Hope I may have given a better idea of what's happening.



[0] Message Index

[#] Next page

Go to full version