Recent

Author Topic: Error while linking Solaris/SPARC GTK2 app  (Read 193 times)

AlexTP

  • Hero Member
  • *****
  • Posts: 1961
    • UVviewsoft
Error while linking Solaris/SPARC GTK2 app
« on: November 24, 2022, 10:34:52 am »
Code: [Select]
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lm
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lc
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lmd5
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -laio
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lrt
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lpthread
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -ldl
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lgdk-x11-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lgtk-x11-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lX11
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lgdk_pixbuf-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lgobject-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lglib-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lgthread-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lgmodule-2.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lpango-1.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lcairo
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -latk-1.0
Error: /home/user/fpcupdeluxe/fpcupdeluxe32/cross/bin/sparc-solaris/sparc-solaris-gld: cannot find -lc
cudatext.lpr(36,0) Error: Error while linking

Free Pascal Compiler version 3.2.3-660-g9b2ba834a6 [2022/08/18] for x86_64

I cross-compile for Solaris SPARC from Linux x64. How to fix these errors?

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1581
Re: Error while linking Solaris/SPARC GTK2 app
« Reply #1 on: November 24, 2022, 11:12:37 am »
For sure.
Somebody with a Sparc Solaris system must send me the required libs.
 :D

MarkMLl

  • Hero Member
  • *****
  • Posts: 5605
Re: Error while linking Solaris/SPARC GTK2 app
« Reply #2 on: November 24, 2022, 11:32:04 am »
I've got a small SPARC system which is /just/ /about/ running Debian, but I have no media- at least that I trust- for Solaris/SunOS and am extremely reluctant to start trying to download stuff.

SPARC hardware is, by now, unobtanium: anything low-end vanished into skips and museums ten years ago, and anything high-end is being sat on by spares vendors in a vain attempt to keep the few remaining corporate users afloat at a price marginally less extortionate than Oracle's.

I think I had Solaris 8 at one point, but no longer. I tried a DLed 10 which was supposedly free for non-corporate use, but it self-destructed suspiciously close to one year after I started using it. I've used- and been generally impressed by- OpenSXCE, but that project was run by a self-identified Russian in Eastern Ukraine and it self-destructed with considerable acrimony on 2014.

That is about as much light as I can throw on the situation at the moment. I know that there's at least one person in the community intermittently hacking on a very old SPARC "lunchbox" system but I suspect that his version of Solaris would be far to old to be relevant.

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

marcov

  • Administrator
  • Hero Member
  • *
  • Posts: 10407
  • FPC developer.
Re: Error while linking Solaris/SPARC GTK2 app
« Reply #3 on: November 24, 2022, 12:56:59 pm »
That is about as much light as I can throw on the situation at the moment. I know that there's at least one person in the community intermittently hacking on a very old SPARC "lunchbox" system but I suspect that his version of Solaris would be far to old to be relevant.

I gave up my pizzabox (SS5) about a decade ago. And it was Linux or NetBSD anyway.

MarkMLl

  • Hero Member
  • *****
  • Posts: 5605
Re: Error while linking Solaris/SPARC GTK2 app
« Reply #4 on: November 24, 2022, 01:21:42 pm »
I gave up my pizzabox (SS5) about a decade ago. And it was Linux or NetBSD anyway.

By that age its TimeKeeper RAM battery had probably died anyway.

The Linux situation is very poor by now. Even if Sun's enthusiasm for it was patchy they paid somebody to maintain the various GNU utilities... something that Oracle put the brakes on as soon as they took over.

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

 

TinyPortal © 2005-2018