Recent

Author Topic: Need a bit of help  (Read 318 times)

iahung

  • New Member
  • *
  • Posts: 22
Need a bit of help
« on: November 19, 2022, 01:20:58 pm »

Leledumbo

  • Hero Member
  • *****
  • Posts: 8523
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Need a bit of help
« Reply #1 on: November 19, 2022, 01:49:42 pm »
Try using older gtk2 libraries, apparently their backward compatibility in minor version doesn't reach ABI level, only header level. Although I'm a bit curious why the hell would you use gtk2 on Windows while you can have the highly guaranteed to work win32 widgetset.

iahung

  • New Member
  • *
  • Posts: 22
Re: Need a bit of help
« Reply #2 on: November 19, 2022, 02:32:52 pm »
Because GTK2/GTK3 worked fine on Windows. Have a look at TextAdept and Geany. Both GTK3 (used to be GTK2) based and working fine on Windows.

Leledumbo

  • Hero Member
  • *****
  • Posts: 8523
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Need a bit of help
« Reply #3 on: November 20, 2022, 09:57:51 pm »
Because GTK2/GTK3 worked fine on Windows. Have a look at TextAdept and Geany. Both GTK3 (used to be GTK2) based and working fine on Windows.
That's not what I mean. They use GTK to have an instant cross platform solution, because they have no LCL. But LCL can use WinAPI directly, so the need for GTK is superfluous. And as you've experienced yourself, it's not "working fine" right now, the LCL interface needs to be patched, unlike the WinAPI.

 

TinyPortal © 2005-2018