Recent

Author Topic: Troubles installing on Ubuntu  (Read 1648 times)

VTwin

  • Hero Member
  • *****
  • Posts: 938
  • Former Turbo Pascal 3 user
Troubles installing on Ubuntu
« on: January 07, 2015, 02:37:46 am »
I'm running Ubuntu in VirtualBox on OS X and run into dependency problems  with libgtk2.0-dev not installed. I can't figure out how to solve this. I'd appreciate any tips. Thanks!

Cheers,
Frederick
“Talk is cheap. Show me the code.” -Linus Torvalds

Free Pascal Compiler 3.2.0
macOS 10.13.6: Lazarus 2.0.10 (64 bit Cocoa)
Ubuntu 18.04.3: Lazarus 2.0.10 (64 bit on VBox)
Windows 7 Pro SP1: Lazarus 2.0.10 (64 bit on VBox)

kapibara

  • Hero Member
  • *****
  • Posts: 532
Re: Troubles installing on Ubuntu
« Reply #1 on: January 07, 2015, 03:08:31 am »
Have you tried installing the libraries?

Code: [Select]
sudo apt-get install libgtk2.0-dev
Then run the command

Code: [Select]
sudo dpkg -i *.deb
« Last Edit: January 07, 2015, 03:17:57 am by kapibara »
Lazarus trunk / fpc 3.0.4 / Debian 10 - 64 bit

VTwin

  • Hero Member
  • *****
  • Posts: 938
  • Former Turbo Pascal 3 user
Re: Troubles installing on Ubuntu
« Reply #2 on: January 07, 2015, 02:20:23 pm »
Thanks kapibara!

No, I couldn't remember how to do it.

Code: [Select]
sudo apt-get install libgtk2.0-dev
Gave me a lot of unmet dependencies, but suggested I run:

Code: [Select]
sudo apt-get -f install
which did the trick. Much appreciated!

Cheers,
Frederick
“Talk is cheap. Show me the code.” -Linus Torvalds

Free Pascal Compiler 3.2.0
macOS 10.13.6: Lazarus 2.0.10 (64 bit Cocoa)
Ubuntu 18.04.3: Lazarus 2.0.10 (64 bit on VBox)
Windows 7 Pro SP1: Lazarus 2.0.10 (64 bit on VBox)

 

TinyPortal © 2005-2018