Forum > macOS / Mac OS X

Lazarus on MacOS reporting stackoverflow

<< < (2/3) > >>

Jonas Maebe:
It's probably an error in the checking logic (or rather the setup). But as mentioned before: compiler-generated stack overflow checking is not very useful any more on modern operating systems (unless you want to limit your stack usage to a certain amount and have the program tell you if you exceed it).

So its a matter of stopping the debugger to stop checking this ... I have not seen that in the options. Might need a new pair of glasses ? Anybody ?

Jonas Maebe:
In the "Debugging" subsection of the Project -> Compiler Options, deselect "Stack (-Ct)" (for the Debug configuration).

You have found my glasses :) Thanks !! 8)

I had a similar problem in MacOS Monterey.  See this thread:,61043.msg458143.html#msg458143

Turning the stack check off kind of solved the problem.
I am not sure that it was not caused by the new security implemented in Big Sur and Monterey.  You know signing, notarizing, hardening, etc.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version