Recent

Author Topic: I have error on MacOS M1  (Read 353 times)

pla31jd

  • Newbie
  • Posts: 2
I have error on MacOS M1
« on: November 11, 2022, 03:36:42 am »
hello
I install Lazarus on my Mac M1
it show info when I run app:

Error: ld: library not found for -lgtk-3.so.0

can you help me ?
kind regards

PascalDragon

  • Hero Member
  • *****
  • Posts: 4868
  • Compiler Developer
Re: I have error on MacOS M1
« Reply #1 on: November 11, 2022, 07:35:22 am »
Did you change your WidgetSet from Cocoa (the correct setting for macOS) to Gtk3?

pla31jd

  • Newbie
  • Posts: 2
Re: I have error on MacOS M1
« Reply #2 on: November 14, 2022, 01:59:50 am »
Did you change your WidgetSet from Cocoa (the correct setting for macOS) to Gtk3?

Thanks!!!
I try to change my WidgetSet  from Gtk3 to Cocoa, it work! :)
I use Delphi for 10 years,but Lazarus I am a beginner, I like Lazarus, a great IDE !
thank you for your support!

 

TinyPortal © 2005-2018