Forum > macOS / Mac OS X

installing 2.2.4 Mac M1


Grahame Grieve:
I followed the instructions to install Lazarus 2.2.4 on my Mac m1:

They worked sweet, but my programs won't run under the debugger. Perhaps that's because it installs all x86_64, so I go to the instructions here as guided:

the instructions say that to Compile a native AArch64 compiler from the FPC trunk source

    make distclean

But it doesn't say where you go to run this. I run it and get

    make: *** No rule to make target `distclean'.  Stop.   

So it seems as if I need to be in a particular folder, but I don't know what that folder is?

I figure that the answer to my is really simple, but I don't know what the answer is.

Grahame Grieve:
I still never figured that out, but this works perfectly for me:

--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---    git clone -b fixes_2_2 laz_fixes    cd laz_fixes    make distclean all LCL_PLATFORM=cocoa CPU_TARGET=aarch64 bigide         open --args "--pcp=~/.laz_fixes"    


[0] Message Index

Go to full version