Author Topic: installing 2.2.4 Mac M1  (Read 669 times)

Grahame Grieve

  • Sr. Member
  • ****
  • Posts: 344
installing 2.2.4 Mac M1
« on: October 25, 2022, 06:28:06 am »
I followed the instructions to install Lazarus 2.2.4 on my Mac m1:

They worked sweet, but my programs won't run under the debugger. Perhaps that's because it installs all x86_64, so I go to the instructions here as guided:

the instructions say that to Compile a native AArch64 compiler from the FPC trunk source

    make distclean

But it doesn't say where you go to run this. I run it and get

    make: *** No rule to make target `distclean'.  Stop.   

So it seems as if I need to be in a particular folder, but I don't know what that folder is?

I figure that the answer to my is really simple, but I don't know what the answer is.

« Last Edit: October 25, 2022, 06:33:48 am by Grahame Grieve »

Grahame Grieve

  • Sr. Member
  • ****
  • Posts: 344
Re: installing 2.2.4 Mac M1
« Reply #1 on: October 31, 2022, 12:25:01 pm »
I still never figured that out, but this works perfectly for me:

Code: Bash  [Select][+][-]
  1.     git clone -b fixes_2_2 laz_fixes
  2.     cd laz_fixes
  3.     make distclean all LCL_PLATFORM=cocoa CPU_TARGET=aarch64 bigide    
  4.     open --args "--pcp=~/.laz_fixes"  


TinyPortal © 2005-2018