Recent

Author Topic: Debugger errors; How to fix it  (Read 438 times)

AL

  • Sr. Member
  • ****
  • Posts: 252
Debugger errors; How to fix it
« on: October 18, 2022, 04:44:40 pm »
I am using lazdebuggerlldb  (lldb with fpdebug) in MacOs 12 Monterey
 
When I use DWARF 3 I get these errors and cannot run the program.
Any idea how to solve this?
Thank you


==================================================
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 108 at offset 0x0000398b, valid abbreviations are 1-58
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 99 at offset 0x00000853, valid abbreviations are 1-57
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 440 at offset 0x00000476, valid abbreviations are 1-59
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 108 at offset 0x00000b75, valid abbreviations are 1-65
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 121 at offset 0x000002ed, valid abbreviations are 1-61
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 68 at offset 0x00000593, valid abbreviations are 1-23
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 22 at offset 0x000003c8, valid abbreviations are 1-18
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 22 at offset 0x00000220, valid abbreviations are 1-16
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 22 at offset 0x00000350, valid abbreviations are 1-19
Error: warning: DWARF unit at offset 0x00000000 contains invalid abbreviation 80 at offset 0x00000548, valid abbreviations are 1-23
Laz 2.1.0, fpc 3.3.1, Win10
Laz 2.2.5, fpc 3.3.1, MacOS Monterey running on VMWare/Win 10
Laz 2.1.0  fpc 3.3.1 Ubuntu 20.04

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 8601
  • Debugger - SynEdit - and more
    • wiki
Re: Debugger errors; How to fix it
« Reply #1 on: October 18, 2022, 05:52:48 pm »
Good question. This could be a limitation in lldb, but also something that FPC gets wrong.

You can try to use "dwarf with sets" instead.

And if that does not work, add the custom option  --godwarfcpp  to the compiler opts. Though, it may depend on the fpc version if that does any good.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 8601
  • Debugger - SynEdit - and more
    • wiki
Re: Debugger errors; How to fix it
« Reply #2 on: October 19, 2022, 07:31:12 pm »
Is your FPC 3.3.1 recent? That is newer than the 10th Oct ?

There may be a bug in FPC that was introduced around that date

AL

  • Sr. Member
  • ****
  • Posts: 252
Re: Debugger errors; How to fix it
« Reply #3 on: October 23, 2022, 03:38:04 pm »
Yes installed Oct 18 !
Should I install an earlier version?
Laz 2.1.0, fpc 3.3.1, Win10
Laz 2.2.5, fpc 3.3.1, MacOS Monterey running on VMWare/Win 10
Laz 2.1.0  fpc 3.3.1 Ubuntu 20.04

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 8601
  • Debugger - SynEdit - and more
    • wiki
Re: Debugger errors; How to fix it
« Reply #4 on: October 23, 2022, 04:21:03 pm »
Yes installed Oct 18 !
Should I install an earlier version?

In the meantime it has been fixed. So you can update to the latest revision on the main branch.

 

TinyPortal © 2005-2018