Recent

Author Topic: [SOLVED] My buttons are NOT flat anymore.  (Read 322 times)

CM630

  • Hero Member
  • *****
  • Posts: 1018
  • Не съм сигурен, че те разбирам.
    • http://sourceforge.net/u/cm630/profile/
[SOLVED] My buttons are NOT flat anymore.
« on: September 13, 2022, 12:13:31 pm »
I am not sure if this is the right section of the forum.
After enabling “Include version info in executable” in Project/Project Options.../Project Options/Version info the buttons of my app are not flat anymore. I have disabled “Include version info into executable” but still the buttons are not flat.

These buttons are tBitBtn and tSpeedButton.
The project is in a google drive and it showed some errors in writing some temp files while building the app, so I am not sure if “Include version info into executable” has something to do with the problem or google drive is the guilty one.
Copying the project to the hard drive did not help.
“Clean up and build” did not help.

Hopefully someone can tell me a way to fix the issue.


« Last Edit: September 13, 2022, 12:40:50 pm by CM630 »
Лазар 2,2,4 32 bit; FPC3,2,2; rev: Lazarus_2_2_4 on W10 64bit.

wp

  • Hero Member
  • *****
  • Posts: 10268
Re: My buttons are NOT flat anymore.
« Reply #1 on: September 13, 2022, 12:36:07 pm »
You probably unchecked the box "Use manifest resource (and enable themes)" in the project options.

CM630

  • Hero Member
  • *****
  • Posts: 1018
  • Не съм сигурен, че те разбирам.
    • http://sourceforge.net/u/cm630/profile/
Re: My buttons are NOT flat anymore.
« Reply #2 on: September 13, 2022, 12:40:36 pm »

You probably unchecked the box "Use manifest resource (and enable themes)" in the project options.

It was not me who unchecked it - I have tried the same on another copy of the project (an older version I found somewhere on the disks) and the buttons got changed the same way when I enabled “Include version info in executable” .
But indeed it was unchecked in my project, checking it fixed the issue.
Thanks!
« Last Edit: September 13, 2022, 12:42:31 pm by CM630 »
Лазар 2,2,4 32 bit; FPC3,2,2; rev: Lazarus_2_2_4 on W10 64bit.

wp

  • Hero Member
  • *****
  • Posts: 10268
Re: [SOLVED] My buttons are NOT flat anymore.
« Reply #3 on: September 13, 2022, 12:50:41 pm »
Just checked it on my Laz/main installation: Checking "Include version info in the executable" does not uncheck "Use manifest resource" here...

Did you once click on the "Set compiler options as default" at the bottom left? I found that this can lead to some unintentional side-effects somewhere else. I rememeber that I once was annoyed by having to uncheck the "Win32 gui application" box in "Config and Target" for commandline programs and selected this as default (by the "Set compiler options as default" checkbox). Later I noticed that all my GUI programs now open a console window like the non-GUI programs...

CM630

  • Hero Member
  • *****
  • Posts: 1018
  • Не съм сигурен, че те разбирам.
    • http://sourceforge.net/u/cm630/profile/
Re: [SOLVED] My buttons are NOT flat anymore.
« Reply #4 on: September 13, 2022, 01:18:54 pm »
I have converted this app from Delphi source a year or two ago.
Maybe some mess was created there.
I have just opened even an older copy of the source - the buttons look as they should, but "Use manifest resource" is unchecked.


“Set compiler options as default” is disabled there.
It is disabled in the project, that have become damaged, too.
Лазар 2,2,4 32 bit; FPC3,2,2; rev: Lazarus_2_2_4 on W10 64bit.

tetrastes

  • Sr. Member
  • ****
  • Posts: 251
Re: [SOLVED] My buttons are NOT flat anymore.
« Reply #5 on: September 13, 2022, 03:04:53 pm »
I have converted this app from Delphi source a year or two ago.

I suppose that there was manifest in resource file generated by Delphi. As you checked “Include version info in executable”, Lazarus rewrote resource file, while "Use manifest resource (and enable themes)" was not checked...

 

TinyPortal © 2005-2018