Forum > Editor

IDE windows - Locked in dock

<< < (2/2)

Nicole:
Thank you so much for the image!
I have wondered all the time, what these strange grafics may be! These were docking handles!
These were the good news.

The bad news: Those docking handles had dissappeared.
I could not find them anywhere anymore. I tried all the menues to make them visible. Nothing.

I am afraid, I uninstalled the AnchorDocking-thing for the second time.  :'(
It is a pity, because I liked this docking.
Is there another "better" docking manager? I am afraid not, beause it seems rather hard to write such a thing?

af0815:

--- Quote from: Nicole on July 19, 2022, 10:42:20 am ---I am afraid, I uninstalled the AnchorDocking-thing for the second time.  :'(
It is a pity, because I liked this docking.

--- End quote ---
You only need to reset the values. In your lazarus config dir you find a files called enviromentsoptions.xml back this up and go inside of Lazarus , select the splitter and click rigth, the activate 'show header'. Maybe you have mishit this.

Edit: It looks like indeed a bug. If you hit this, you will never can go back.

Close Lazarus. Open the enviromentsoptions.xml and search for a line with "Settings ShowHeader="False"" remove the ShowHeader="False" or change it to True. After reopen the dockings will be shown.


--- Quote ---              </Item1>
            </Item1>
          </Nodes>
        </MainConfig>
        <Settings ShowHeader="False" SplitterWidth="3"/>
      </AnchorDocking>
    </Desktop2>
  </Desktops>
</CONFIG>

--- End quote ---

The SplitterWidth is the size of the splitter, normal = 4 i have changed this to 3

Backup: Go in Lazarus to menu Tools->Desktops... there is a Export Button - use this :-)

To avoid unwanted changes. Open the dialog and remove the autosave option. You can always store your changes with Save active desktop as.. and give the same name as before

Navigation

[0] Message Index

[*] Previous page

Go to full version