Forum > GTK

In some situation, CudaText GTK2 build silently exits


I cannot make the simple repro-demo for this issue.
So just read how to repeat it in the open source project CudaText.

What I tried to catch it in IDE:
- made breakpoint in TApplication.Terminate
- made breakpoint in 'finalization' section of some app unit

None helps - breakpoints are not handled when this bug happens. Debugger cannot see it.
(But breakpoints work OK if I do normal app exit).

Qt5 build works OK.

I got some info in Terminal when bug happens!

--- Quote ---user@PC:~$ cudatext
Gtk-Message: 22:52:37.523: Failed to load module "overlay-scrollbar"
Gtk-Message: 22:52:37.531: Failed to load module "canberra-gtk-module"
The program 'cudatext' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 34624 error_code 3 request_code 12 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

--- End quote ---

It is Ubuntu 20.04 x64.
If  I run 'cudatext --sync' bug does NOT happen.


[0] Message Index

Go to full version