Forum > General

Cannot clean and Build - errors

(1/3) > >>

Mint-MATE 20.3, Laz 2.2.2

Recently updated to 2.2.2 and getting some weird stuff (kept rolling back to previous code) when compiling so tried "Clean and build."

I am getting the following error and whole list of files that need deleted with "sudo" access.

--- Quote ---Unable to delete file "/usr/share/lazarus/2.2.2/components/buildintf/units/x86_64-linux/BuildIntf.compiled".

--- End quote ---

How do I fix this?

Do I need to manually do it?


Just to get the ball rolling (a) where or how did you get that Lazarus and (b) what does an ls -l show you on that file?

Are you actually trying to build a project of your own or rebuild the IDE?


Well, who owns the  file, what are the access rights?

If that is the only issue, and if there is no hidden other issue => just delete the entire folder

--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---rm -rf /usr/share/lazarus/2.2.2/components/buildintf/units

Thanks to both of you for the quick replies. This was all working just fine with 2.0.12 with a project developed over the past year. No Permissions have been changed and only a single User (non-admin) in Mint-MATE.

This morning, without even trying yesterday's code, I decided to reinstate the entire project Folder from Thursday's backup. When I compiled and ran, it presented a login option that I had added yesterday. It should not even have know about that.

I then tried a Build of project (using Thursday's backup code) but it still drew on yesterday's code. That's why I tried the Clean and Build option, crashed, then came here with the error.

I had looked in the /usr/ ... folder but unsure just how deep to go before deleting but will bite the bullet and delete that /usr/.../units folder as suggested.

back soon. :)

I give up. That would not compile anything after deleting that /usr/ ...2.2.2 ... /units folder.

I have rolled back to 2.0.12 before I installed 2.2.2 few days back.

The 2.2.2 looks like it needs some more work for Linux.


[0] Message Index

[#] Next page

Go to full version