Forum > Editor

[solved] Colors - all over now

(1/1)

Nicole:
The IDE formatted comments in the source text bold and blue.
This I wanted to chance in non-bold and green (like Delphi).

It did not work, the IDE just did not do it.

I wanted the old colors back and chose "reset to defaul"...
Now there are no colors at all.
All my source is the same and black now.

What can I do to get any colors back?


Thanks

Handoko:
Have you this below? (see img1)
Lazarus main menu > Tools > Options > Editor > Display > Colors > Reset all

Or you can delete your editoroptions.xml to let Lazarus regenerate the file using the default settings. Use your File Manager's file finding feature to locate the file. Make sure you have backup in case something bad happens. (see img2)

Martin_fr:

--- Quote from: Nicole on July 02, 2022, 01:59:28 pm ---The IDE formatted comments in the source text bold and blue.
This I wanted to chance in non-bold and green (like Delphi).

--- End quote ---
I am quite sure that will work....
Not sure though were you may have gone wrong.

When you have your colors back (and backup your editor options xml file).
Go back to the dialog.
Choose the "comment" from the tree view.
And only change the foreground color (and the bold checkbox).

Touch nothing else.



--- Quote ---Now there are no colors at all.

--- End quote ---

Have you disabled "use highlight" at the top?

Also, in the editor, right click, and check in the context menu, that the highlighter is pascal.

Nicole:
Lieben Dank an alle!
Ich löschte das xml-file, doch danach war es noch immer schwarz-weiß.
Erst "use highlight" machte die Sache endlich wieder bunt und leichter zu bearbeiten.

sorry for the wrong language:
Many thanks to all: I deleted the xml-file, but the colors did not return.
"highlight" made the difference.

PascalDragon:
English, please. ;D

Navigation

[0] Message Index

Go to full version