Forum > General

[SOLVED] Application Main Form didn't Show

(1/2) > >>

incendio:
Hi guys,

I am using Lazarus 2.0.12 on Windows 10 64.

Created new application, add a button and run it, but the application main form didn't show.

On Lazarus Title Windows, there is a title ... debugging ...

Project could not be stopped (with Ctrl F2), I have to forced close Lazarus to stop the project.

What is wrong?

Attached the sample project.

Handoko:
I tested it on Linux GTK2, everything was okay.

I heard some has problem running Lazarus generated binaries with Windows Defender, have you tried to generate and run the binary when Defender is disabled? Or try to run the program using other computers?

The possible problems I can think of are virus/antivirus issues, damaged Lazarus installation, OS related problems, disk file system problems both logical and hardware issues.

Try to run the binaries you created on other computer first. Later, try to reinstall  your Lazarus preferable a complete re-installation. Also download and try different versions of Lazarus. Make sure your system and hardware is okay, run disk test, virus checking, etc.

derek.john.evans:
Runs fine here (Raspberry Pi). Try disabling the debugger via "Tools->Options->Debugger->General". Set debugger type to "(none)"

Are you running the 64bit version of Lazarus? There might be a bug in your setup. I personally don't use the debugger, but some people love it.

If that fixes your problem, then you might have to do without it.

incendio:

--- Quote from: derek.john.evans on June 21, 2022, 07:37:47 am ---Runs fine here (Raspberry Pi). Try disabling the debugger via "Tools->Options->Debugger->General". Set debugger type to "(none)"

Are you running the 64bit version of Lazarus? There might be a bug in your setup. I personally don't use the debugger, but some people love it.

If that fixes your problem, then you might have to do without it.

--- End quote ---
App still won't run, but this time, I can stop the project without need to forced closed Lazarus.


--- Quote from: Handoko on June 21, 2022, 07:32:29 am ---I tested it on Linux GTK2, everything was okay.

I heard some has problem running Lazarus generated binaries with Windows Defender, have you tried to generate and run the binary when Defender is disabled? Or try to run the program using other computers?

The possible problems I can think of are virus/antivirus issues, damaged Lazarus installation, OS related problems, disk file system problems both logical and hardware issues.

Try to run the binaries you created on other computer first. Later, try to reinstall  your Lazarus preferable a complete re-installation. Also download and try different versions of Lazarus. Make sure your system and hardware is okay, run disk test, virus checking, etc.

--- End quote ---
I don't have Windows Defender Enabled, but I have Commodo Firewall.

On Commodo Settings, Firewall and HIPS is on, set HIPS to off and problem solved.

Strange though, I have a few application build with Lazarus and runs OK with HIPS on, don't know why this one has problem.

Thanks to all for your help.

Thaddy:
Note that by now both Windows Defender and Windows Firewall are as good as, or even superior to third party solutions.
It is best to leave those third party solutions alone unless you are a professional and need some specific feature.
But then again, check if everything is setup correctly. The defaults are a good start and usually sufficient.
Defender does not usually interfere with FPC applications, btw. Windows 10/11.

I only run fail2ban and consorts ( certificates) on my home servers and that is more than enough.

Navigation

[0] Message Index

[#] Next page

Go to full version