Recent

Author Topic: LAMW - New Module in Laz4Android fails  (Read 310 times)

Pkandet

  • Newbie
  • Posts: 4
LAMW - New Module in Laz4Android fails
« on: June 10, 2022, 09:06:57 am »
Hej
When I start a Console app everything is fine but when I start New module in laz4android it says "3000-preview is not invalid integer"
Where do those numbers come from? And how do I fix it so I can run a program  :D


NEWS;
I can tell, after reinstalling old model and again using latest Lazarus 2.2.2, I found out ABI30 (in Sdk manager) was missing and needed to be installed, but before I installed the upgrade ABI30 it worked but asked me to update, so I updated and then came the error again after the update.
Hope the explanation makes sense, otherwise ask :-)
« Last Edit: June 11, 2022, 11:42:59 am by Pkandet »

rsu333

  • Jr. Member
  • **
  • Posts: 92
Re: LAMW - New Module in Laz4Android fails
« Reply #1 on: June 13, 2022, 04:19:08 pm »
Better way totally delete the directory and reintall LAMW

jmpessoa

  • Hero Member
  • *****
  • Posts: 2127
Re: LAMW - New Module in Laz4Android fails
« Reply #2 on: June 13, 2022, 08:29:26 pm »
Quote
laz4android it says "3000-preview is not invalid integer"....


Delete [if there is any]  "preview"  into your  android "sdk\platforms"  or "sdk\build-tools"  folders....
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

 

TinyPortal © 2005-2018