Recent

Author Topic: App input while debugging on MacOS  (Read 415 times)

d4eva

  • New Member
  • *
  • Posts: 16
App input while debugging on MacOS
« on: June 05, 2022, 11:14:49 pm »
When I debug my app on MacOS, I can click on buttons etc. but I cannot edit Edit or Memo text, the input just doesn't work.
When I start the compiled app from terminal, I see that the input is sent to the terminal, i.e. the keys pressed appear as characters in the terminal, but not the app.
Am I doing something wrong?


MarkMLl

  • Hero Member
  • *****
  • Posts: 5192
Re: App input while debugging on MacOS
« Reply #1 on: June 06, 2022, 09:32:56 am »
I'm by no means a Mac guru, but in the general case that doesn't sound right. I'd suggest adding far more detail about the actual OS version etc. that you've got, and it might be worth appending your test program if that's feasible /in/ /case/ you've got something odd in the code.

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

d4eva

  • New Member
  • *
  • Posts: 16
Re: App input while debugging on MacOS
« Reply #2 on: June 06, 2022, 12:37:16 pm »
Huh, I found the reason. It is happening when "Use Application Bundle for running and debugging" option is not checked under the Project Options.
« Last Edit: June 06, 2022, 12:59:15 pm by d4eva »

 

TinyPortal © 2005-2018