Forum > QT

After upgrade to Laz 2.2.2. from 2.2.0, project can't run

<< < (2/3) > >>

440bx:

--- Quote from: Thaddy on May 24, 2022, 09:45:15 pm ---Get the point?

--- End quote ---
Anyone who can read got the point: you're in a bad mood... a 64bit bad mood...  congratulations on your upgrade from 32bit.

@OP

That message indicates a missing dll, did the message include the dll name ?... that information would be useful.

Gald:
Now you guys talking, I just remembered that these days I set to off of some Windows components.
I have no idea why QT5 needs something like that to run, while native Lazarus remains OK.

As far as I remember, I had deactivated the following:


* MS Print in PDF
XPS Writer
Media Resource (Win Media Player)
Internet Client Print
*
I did it because I was having some lag on System, and it does fix the problem.

Unfortunately, I've tried to activate it again with no results.

Nothing in this list looks like something QT needs to run.

Gald:
Just realized that another projects ask for Qt5Pas1.dll.

I found one in C:\WindowsSysWOW64 and another on Git.

I tried both in the application folder with both projects and now the error message has changed:

Execution Stopped with exit-code -107371701 ($C000007B).

440bx:

--- Quote from: Gald on May 25, 2022, 02:00:34 am ---Execution Stopped with exit-code -107371701 ($C000007B).

--- End quote ---
That means the system considered the dll "bad".  Most commonly a dll is considered "bad" when it doesn't match the bitness of the program that causes it to load, e.g, a 32bit program attempting to load a 64bit dll or viceversa.

It seems you could benefit from a tool that lists all the values of NTSTATUS (which is what that number you got is) and what they mean, you can find one at https://forum.lazarus.freepascal.org/index.php/topic,46911.msg335125.html#msg335125

along with a tool that lists all the Win32 LastError (from GetLastError) and their textual meaning.

To determine the bitness of the dll and the program, there are a number of tools that will do that for you, among them Dumpbin, PeView, CFF explorer (one of my favorites) and PeBytesF (my personal PE viewer which is available here in the forums as a download) and quite a few others that Google will serve on a silver platter to you.

HTH.

Gald:
I saw this on the wiki:


--- Quote ---Windows
There is a Q5Pas1.dll binary available.

x86: https://gitlab.com/freepascal.org/lazarus/binaries/-/raw/main/i386-win32/qt5/Qt5Pas1.dll?inline=false
no 64-bit version yet.
--- End quote ---

So the problem seems to be that I'm using Lazarus 64 bit.
Gonna install 32x now.

Thank you all!  :D

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version