Recent

Author Topic: installation warning  (Read 2516 times)

systems

  • New Member
  • *
  • Posts: 18
Re: installation warning
« Reply #15 on: May 22, 2022, 06:59:05 pm »
some installers are more advanced, and check if the user installing is admin or not

if the user is not admin, the installer will install everything locally
if the user is admin, the installer will ask if he want to install only for this one admin user, or for all users (i usually see it asked like this for just you or all users)

also, i think we need to have more info on the dlls installed, like version number
and does anyone know which version of openssl is being installed, 1.1.1 or 3.0.3 ?
« Last Edit: May 22, 2022, 07:09:30 pm by systems »

tetrastes

  • Full Member
  • ***
  • Posts: 221
Re: installation warning
« Reply #16 on: May 22, 2022, 08:38:55 pm »
Perhaps it needs.
However apparently users ask here, when something doesn't work. And then they have choice according to answers: make it work as is, or wait when it will be corrected.
I have forgotten the best one: correct it by himself and help or join Lazarus team  ;)
« Last Edit: May 22, 2022, 08:43:03 pm by tetrastes »

tetrastes

  • Full Member
  • ***
  • Posts: 221
Re: installation warning
« Reply #17 on: May 22, 2022, 08:49:03 pm »
and does anyone know which version of openssl is being installed, 1.1.1 or 3.0.3 ?
1.0.2

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1983
  • Former Delphi 1-7, 10.2 user
Re: installation warning
« Reply #18 on: May 23, 2022, 12:12:22 am »
and does anyone know which version of openssl is being installed, 1.1.1 or 3.0.3 ?
1.0.2

That's not good! OpenSSL 1.0.2 (LTS)   January 22, 2015 (release date)   December 31, 2019 (end of life).
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

systems

  • New Member
  • *
  • Posts: 18
Re: installation warning
« Reply #19 on: May 23, 2022, 01:49:09 am »
and does anyone know which version of openssl is being installed, 1.1.1 or 3.0.3 ?
1.0.2

May I ask, how did you know, where is that documented, I googled it a bit, but could not find it

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1983
  • Former Delphi 1-7, 10.2 user
Re: installation warning
« Reply #20 on: May 23, 2022, 03:54:49 am »
I checked the DDL info on Win11 - see image - it looks like 1.0.2

Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

tetrastes

  • Full Member
  • ***
  • Posts: 221
Re: installation warning
« Reply #21 on: May 23, 2022, 11:00:30 am »
You can also get some more information with some program for reading resources, e.g. with windres provided with FPC:

GetMem

  • Hero Member
  • *****
  • Posts: 3760
Re: installation warning
« Reply #22 on: May 23, 2022, 11:19:15 am »
Hopefully it will be updated to openssl 1.1.1o soon. Won't fix the OP's original problem though.

Thaddy

  • Hero Member
  • *****
  • Posts: 11764
Re: installation warning
« Reply #23 on: May 23, 2022, 12:08:10 pm »
On debian, type openssl version
I get 1.1.1d
Under cygwin64/win64
I get 1.1.1f
Black themes should be banned.

systems

  • New Member
  • *
  • Posts: 18
Re: installation warning
« Reply #24 on: May 23, 2022, 07:54:54 pm »
Hopefully it will be updated to openssl 1.1.1o soon. Won't fix the OP's original problem though.

Well, if version 1.1.1 doesnt have any known issue or vulnerabilities, this would be a good enough solution
i think they should consider moving to version 3.0.3 or even to libressl though

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1983
  • Former Delphi 1-7, 10.2 user
Re: installation warning
« Reply #25 on: May 24, 2022, 02:34:12 am »
i think they should consider moving to version 3.0.3 or even to libressl though

LibreSSL is not ABI compatible with any release of OpenSSL, or necessarily earlier releases of LibreSSL.
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

GetMem

  • Hero Member
  • *****
  • Posts: 3760
Re: installation warning
« Reply #26 on: May 24, 2022, 06:45:08 am »
Openssl is updated to 1.1.1o in main. Please test.
The next logical step is the 3.x series, but we need more testing.

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1983
  • Former Delphi 1-7, 10.2 user
Re: installation warning
« Reply #27 on: May 24, 2022, 07:42:20 am »
If you know what "Globally Install" actually means the solution is obvious. And. apparently users do not connect the dots when it doesn't work. Perhaps the installer needs to say "Install OpenSSL libraries in the Windows directory (requires administrator permissions)". The description matches the actions performed and tells you exactly what you need.

So it would not be overlooked, I submitted an enhancement request to this effect. See PR: https://gitlab.com/freepascal.org/lazarus/lazarus/-/issues/39766
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

Thaddy

  • Hero Member
  • *****
  • Posts: 11764
Re: installation warning
« Reply #28 on: May 24, 2022, 07:44:37 am »
3 series is an architectual rewrite, so probably needs work. 1.1.1 is under active maintenance.
You can still run into trouble if you have not been paying attention, because many protocols have been removed from 1.1.1
- ssl2/3/tls1.0
- some key exchanges
Only use tls1.1, tls 1.2 or higher. There is no ssl in openssl, only tls.... :o %) :-X
Many people still have code that uses hardcoded ssl and that is wrong:
The handshake should be made latest first so starting with the strongest.
« Last Edit: May 24, 2022, 07:51:15 am by Thaddy »
Black themes should be banned.

systems

  • New Member
  • *
  • Posts: 18
Re: installation warning
« Reply #29 on: May 24, 2022, 08:20:10 am »
Openssl is updated to 1.1.1o in main. Please test.
The next logical step is the 3.x series, but we need more testing.

How can we test, when will the install file be updated?
I can confirm that the file i download around 4 days ago lazarus-2.2.2-fpc-3.2.2-win64.exe, still installs version 1.0.2

 

TinyPortal © 2005-2018