Forum > Lazarus

Lazarus Release 2.2.2

<< < (12/12)


--- Quote from: Martin_fr on June 21, 2022, 10:29:21 pm ---Or your app depends on some dll, that you did not put in the new install?

--- Quote ---Execution stopped with exit-code
--- End quote ---
This usually means that your app was started [(1)] (and for that you must have some debugger (if your setting is gdb, then some gdb.exe)), and your app did then quit

[(1)] The exe file was opened by the OS, but it may (or may not) have failed before any code was executed.

- This could be, that the IDE config is hard coded to the 64 bit debugger (though IIRC that causes a diff error).

- Or it could be, that the OS failed to load dependencies.

- Or it could be that your Anti-Virus killed the process.

--- End quote ---
No, it's blank TForm 32 bit app. AV is off.

I suspect that 64 bit debugger tried to debug 32 bit app.

Hi! It seems the binaries have not been made for MacOs 32bit:

I've tried to compile Lazarus 2.2.2 and 2.2.0 using Lazarus 2.0.12 but without success.

In the folder for 2.2RC1, the files does not seem to match:

There seem to be FPC for 64bit and Lazarus 2.0.12 for 64bit.

Are there instructions on how to make those files?

Try using fpcupdeluxe


[0] Message Index

[*] Previous page

Go to full version