Forum > Translations

Translation does not work no matter what


Running Laz 2.2 on Win10/64. If I create a new app, turn on i18n and set both check boxes, folder etc, include the DefaultTranslator in the uses clause, have ResourceString set etc build, I get the .pot file in the language folder. However, if I load my app, which was originally created with a much older version of laz, 1.8 I think, is now compiling fine in 2.2, I can't get the translator to create the .pot files, no matter what I do. I followed all instructions, even did exactly what the examples/translate project do, to no avail. I also clean the files like the ppu, lrs etc to no avail. Even building from the menu not the shortcut keys. I tried anything I can think of!!!

Could it be that because my project was created using an older version of Laz? Anyone else have this problem?

No Alienizering, it won't be because of the applications history.  I suspect Lazarus is waiting to see a change to the app before generating new po files.

Have you tried ProjectOptions -> i18n -> Force Update PO files on next Build ?  Small tick box lower part of options screen.


Thanks for your reply Davo. Yes, I have tried that too. I even loaded the forms, change something.

I've noticed something in my code, instead of having...

{$R *.lfm}

I didn't have {$R *.lfm} but I had {$R *.lrs} under the initialization section. So I changed all my forms and now I do get the .pot file but only for the main form not the other. Any ideas why I don't get the .pot files for the other forms?

Thanks, I appreciate you taking the time to help me.

I got it to work fine now. I had to include the files in the project inspector, then I had to move each forms a bit and save, so it create the .lrt file for it. Doing a build now create a single .pot file with everything in it.


[0] Message Index

Go to full version