Recent

Author Topic: Can't create new LAMW Project  (Read 352 times)

Sirius Black

  • New Member
  • *
  • Posts: 22
Can't create new LAMW Project
« on: May 16, 2022, 11:59:16 pm »
Hi Everyone,

I can't create a new project for LAMW [GUI] Android Module. The error message is '3300-rc3 is not valid integer'. This error occurred after I click OK at new project dialog.

I'm using:
Lazarus 2.2.0 (rev lazarus_2_2_0)
FPC 3.2.2 x86_64-win64-win32/win64

How to fix it?

jmpessoa

  • Hero Member
  • *****
  • Posts: 2119
Re: Can't create new LAMW Project
« Reply #1 on: May 17, 2022, 10:50:12 am »

Hi, Sirius Black!


How did you manage to install Lazarus + LAMW?
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Sirius Black

  • New Member
  • *
  • Posts: 22
Re: Can't create new LAMW Project
« Reply #2 on: May 17, 2022, 11:43:35 pm »
I was use FCUPDeluxe to install lazarus and Free pascal. I was use manual install from open file package menu to install LAMW

ADiV

  • Jr. Member
  • **
  • Posts: 89
    • ADiV Software
Re: Can't create new LAMW Project
« Reply #3 on: May 25, 2022, 08:52:03 am »
Try with New version laz4android2.0.12-FPC3.2.0 released.

https://forum.lazarus.freepascal.org/index.php/topic,57275.0.html

Sirius Black

  • New Member
  • *
  • Posts: 22
Re: Can't create new LAMW Project
« Reply #4 on: May 25, 2022, 11:41:23 pm »
I found the problem. It's the SDK number. I've installed SDK 33.00 rc3, LAMW can't parse the word rc3 as number. I uninstalled SDK 33, the problem solved. Thanks everyone for your help

 

TinyPortal © 2005-2018