Forum > Windows (32/64)

[SOLVED] TPointF Not Found ??

<< < (2/7) > >>

Still no further forward  :(

Following @Winni's suggestion, I've added 'Types' to the list of Units but I still get 'Indentifier not found' error.

Searching for some option setting that points to FPC3.2.2, I see in [Project][Project Options][Compiler Comands] under 'Compiler' 'Command' the entry "$(CompPath)" with further options in the drop-down list :
   T:\Pascal Compiler\bin\i386-Win32\fpc.exe

Now --
Q:\fpc   does not  exist  -  and has never done so  -  selecting that naturally displays a message to that effect  -  so how has that 'path' been created?

Q:\Stable....  does exist and fpc.exe can be found in the ultimate folder.  Selecting that (rather than "$(CompPath)"  )  does start compilation but then shows a message [The Debugger "" does not exist or is not executable] or after a 'Clean & Build' showing hundreds of hints and warnings - fails to complete the compilation  -  it comes to an end but doesn't display the Form.

T:\.....  of course I know calls fpc V 3.0.0  which is back full circle where I started with the TpointF error  -  as does selecting simple fpc.exe

In the past (V1.6) I've always left most 'Options' as the default - really only changing the 'Target File Name', 'Target OS', 'Target CPU Family' or 'Target Processor'.   Naturally I've turned Debugging on and off as needed, but never needed to mess with any other settings.   ---  Oh yes, I have loaded [Icons]  :)

What was expected to a 'jog' or maybe a 'sprint' at worst, seems to have turned into a 'Marathon' with the prospect of becoming a 'double'  %)  - - - -   and I haven't even thought about installing the Cross-Complier for i386 !

Don't play with the settings if you don't know what you are doing. Your project compiles out of the box.

You probably have misconfigured something now. Close the IDE. Go to your project folder. Delete all ppu files. Delete the session file (.lps). Then find your config folder (the one that you needed for the secondary installation) and rename it. When you restart the IDE all your settings are gone and reset to default. Load your project, compile it. It must work. Absolutely test the project that you had uploaded, I cannot tell anything about your other projects.

Sorry to be such a pain WP,  but essentially I haven't 'played with the settings'  -  I have tried the various options that appear to be available but always returned to the 'default' option.

I have now deleted the .ppu & .lps files - also renamed the [Config] directory (though I suspect that that may affect the V1.6 installation - I can easily return it to the original though).

Upon running Laz - as expected, I do get the [Configure Lazarus IDE] dialogue box and can see where I may have mis-understood what was expected about the fppkg.cfg location upon first seeing this dialogue.

This time I used [Restore Fppkg configuration] which presented me with a new screen. Attached is a screen grab.  I then used the [Browse] in the right hand screen to select from the new installation of 3.2.2 but even though fpc.exe and fpcmkcfg.exe are both in the selected folder the warning insists that the compiler is not found!

Looking above the [Browse] button & 'prefix' line, I see a reference to "3.0.0\units ..."  so am thinking that this dialogue is looking for fpc V3.0.0 but that may well be a piece of generic text that hasn't been updated (very much clutching at straws!)

I also see on the left hand screen the fppkg reports that 'the RTL is not installed'  and I've just checked the location of the [Config] directory and it has been re-created with the following text :

GlobalPrefix=T:\Pascal Compiler\
Compiler=T:\Pascal Compiler\bin\i386-Win32\fpc.exe

!!!!!!  %) %) %)

Did you try to simply ignore this fppkg issue and simply press "Start IDE" without "Restore Fppkg Configuration"? I've seen this issue occasionally (I wonder why I did not see it when I tested the installation for my post here), and IIRC, this was the way i got rid of it: "Start IDE". The IDE will start normally, and when you restart it later that issue will be gone (mostly).

This is a message from the Lazarus mailing list by Bernd Mueller:

"the workaround below solves the problem for me.

When the "Configure Lazarus IDE" dialog appears for the first Lazarus
start, one can ignore the Fppkg tab and start the IDE as it was possible
with former Lazarus versions. The (for me annoying) dialog will then no
longer appear when Lazarus starts again.

I could not detect any negative effects. The IDE can recompile itself
and installing packages via the integrated online package manager was
also possible. "

Yes - and I've just done so again  -  and again  - - -   still fires the TpointF error and presumably still thinks that it needs FPC V3.0.0

I suspect the next test is to kill the installation completely and start again but I doubt that I'll know what to do differently  :o

[Edit] posted before I saw your edit WP :(

Just had a thought ---
I could quite easily edit the config file changing the T:\.... to Q:\...
and the =3.0.0  to  =3.2.2

The problen then would be that I would need to change some setting in the Laz options to point to a new Config directory to maintain the original one for V1.6 - - - -  hmmmm...


[0] Message Index

[#] Next page

[*] Previous page

Go to full version