Forum > Windows (32/64)

[SOLVED] TPointF Not Found ??

(1/7) > >>

My first project using Laz 2.2 - a very small test for a larger project, which compiled without error using Laz 1.6 - flags up a TPointF 'Identifier not found' and 'Error in type definition'. This appears in [EasyLazFreeType] which must be called by some other Unit but since this project doesn't yet have any 'Text' to display I'm at a loss to understand why it is even being called.

This project is only 80 lines of code so I've attached a .zip file for evaluation. It has a TPanel upon which is displayed four TShapes.


I don't get an error in Laz2.2/fpc 3.2.2. Maybe there is a unit compiled with the old compiler in your output folder, and the new compiler fails to find the source, or similar. In such compilation issues, the first recipe is to do a "Run" > "Build", and if this does not solve the issue, do a "Run" > "Clean up and Buld".


I have a clean laz stable installed and your project compiles and runs fine no error.

Have you installed any other packages components? if so are they up to date? not ones from years ago you have for 1.6?

TFloatPoint is part of graphmath unit, a lot of things have moved around and even deprecated since 1.6.


TpointF is definded in the unit Types


Thanks all for your input - I suppose the good news is that others find no error  ::)

This was intended to be a 'clean', completely separate, installation of Lazarus/FPC and is on a separate partition as Drive 'Q'. I was concerned that it asked me to point to fppkg.cfg and it seems that the fact that I could only find that as the one created in 2016 (when I first installed FPC/Laz) is the root of this problem!   

Looking in [Project][Options][Show Options][Command line parameters] I see the first line is 'T:\Pascal Compiler\bin\i386-Win32\fpc.exe' which of course points to FPC V3.0.0.

I have now found FPC.exe (V3.2.2) on drive Q - so can confirm the the installation DID include FPC - but it did not create a new fppkg.cfg which I would have thought would be automatic.

My question now is - how do I create an fppkg.cfg with the correct information to point Laz 2.2 to FPC 3.2.2 ?    since I'm fairly certain that this is the root of my problem. There may be other issues that I need to address which may be solved by a "Clean up and Buld" but until I have a valid fppkg.cfg I doubt that I'll move forward.


[0] Message Index

[#] Next page

Go to full version